Question Game start stuttering after upgrading to new CPU

Jun 2, 2020
2
0
10
0
Hello all, I have problem with my PC, I upgraded my CPU from Athlon II X2 245 To Phenom II X4 945 (Old processor yeah, I'm poor I'm sry) with my motherboard Biostar A780L3C, with my old CPU, I don't have any problems while playing games, only I cant do multitasking, after upgrading CPU to Phenom II x4 945, it increased my multitasking performance, but when playing games, it goes stuttering, making the game unplayable, while with my old CPU, I don't have this problem, my CPU temp while playing is around 65C to 71C, any idea what causes this? thanks

Nb: sorry if my English is bad
 
Hello all, I have problem with my PC, I upgraded my CPU from Athlon II X2 245 To Phenom II X4 945 (Old processor yeah, I'm poor I'm sry) with my motherboard Biostar A780L3C, with my old CPU, I don't have any problems while playing games, only I cant do multitasking, after upgrading CPU to Phenom II x4 945, it increased my multitasking performance, but when playing games, it goes stuttering, making the game unplayable, while with my old CPU, I don't have this problem, my CPU temp while playing is around 65C to 71C, any idea what causes this? thanks

Nb: sorry if my English is bad
How much RAM do you have ? With increased number of cores, more RAM is needed.
 
Jun 4, 2020
8
1
15
0
Hello all, I have problem with my PC, I upgraded my CPU from Athlon II X2 245 To Phenom II X4 945 (Old processor yeah, I'm poor I'm sry) with my motherboard Biostar A780L3C, with my old CPU, I don't have any problems while playing games, only I cant do multitasking, after upgrading CPU to Phenom II x4 945, it increased my multitasking performance, but when playing games, it goes stuttering, making the game unplayable, while with my old CPU, I don't have this problem, my CPU temp while playing is around 65C to 71C, any idea what causes this? thanks

Nb: sorry if my English is bad
Interesting, those temperatures aren't too bad but their could still be some possible thermal throttling going on since those temperatures aren't necessarily low. Did you apply thermal paste to the cpu correctly? Also does you cpu read a constant GHz speed? Another problem could be getting power to the cpu. That phenom has a 95watt TDP and your motherboards max wattage support is 95watts. Although this shouldn't be a problem, with an old motherboard, cpu, and especially a bad power supply this could be the cause of the stuttering. What power supply do you have?
 

ASK THE COMMUNITY

TRENDING THREADS