Question Gamepad not letting PC start up

Apr 26, 2020
1
0
10
0
I've owned a Logitech rumblepad F510 for years, thought it hasn't seen much use. I've decided to start using it again and have been doing so for at least a month just fine. Yesterday when i went to turn on my pc, I found that it would not start up and got stuck on the motherboard screen. I immediately thought the worst happened. I attempted several restarts without any change and then finally in the end I decided to unplug everything that was in the front panel (headphones and the aforementioned controller) and immediately the PC started up just fine. I have done several restarts with nothing plugged in, with headphones plugged in and finally with the controller plugged in which is when i confirmed that it's the culprit. I have tried plugging the controller into the back panel and restarting my PC and it worked just fine. What happened to the front panel overnight and why is only the controller the one that interrupts the startup now all of the sudden? I use Windows 10.
 

Ralston18

Titan
Moderator
Update your post to include full system hardware specs.

What PSU is installed: make, model, wattage, age, condition?

Any other USB connected devices (front and back) besides controller and headphones?

Look in Reliability History for error codes, warnings, and even informational events.

Have you tried "going back" to the front ports to determine if the problem repeats?

Maybe switching headphones and controller between front ports. Determine if all front ports do indeed work.

Power down, unplug, open the case. Check the USB power connections to the front ports. Ensure that they are fully and firmly in place.
 

ASK THE COMMUNITY

TRENDING THREADS