Question Games/Benchmarks Crash To Desktop With Device Lost Error

May 23, 2020
1
0
10
0
System:
CPU: I7 7700K
MB: ASUS STRIX Z270G
GPU: ZOTAC 1070 AMP
MEM: 16GB DDR4
PSU: EVGA 600 8Q
Win 10

I'm leaning towards this being a dead/dying component but thought I'd see if anyone could think of something I haven't tried before I go replacing things

Title basically explains the issue - Virtually all games/benchmarks will crash out and close. It's not at all consistent, some games will crash at launch or when I click play (e.g Overwatch, Apex) and some will play for a while before randomly crashing (e.g RDR2, DS3). Furmark and Heaven both crash part way through running as well. The games that do give a decent error all report the device being lost or something similar:
"Unreal Engine is exiting due to D3D device being lost"
"Your rendering device has been lost"

My temps on both my CPU and GPU are well within spec at all times.

Things I've tried:
  • Removed all overclocks from CPU/GPU/Memory
  • DDU my machine and do a clean install of most recent drivers
  • Flashed BIOS to most recent version
  • Memtest (All passed)
  • CPU stress test without GPU stress (no issues)
  • Ran SFC /scannow (Fixed an issue with HyperV but nothing relevant, now comes back clean)
  • Re-seated GPU and memory
  • Ran tests on relevant drives (All report healthy)
The build is about 2 years old and hasn't had any major changes more recently than about 18 months ago. All components were bought new at the time. It has been working perfectly up until a few weeks ago.

Based on all this, I think either my PSU is giving out and is not able to provide enough power to my GPU once it is running at 100%, or my GPU itself is dying.

Obviously I would much rather this be a software/config issue and I just haven't thought to try something, so any thoughts/advice which might save me buying new components would be appreciated!
 

ASK THE COMMUNITY

TRENDING THREADS