Games causing system lockup.


Dec 17, 2012
Ok, so you folks are my last hope before I go pulling and replacing it hoping to solve this issue by process of elimination. Any assistance that can be provided would be much appreciated.

When playing two MMOs in particular, The Secret World and Champions Online, my system locks up completely with no response at all. Powering it off is the only thing I can do when the lock ups happen.

I am going to provide my specs and a list of troubleshooting steps I have taken and hopefully someone on here has an idea or notices something I missed.

Windows 7 Ult N
AMD FX-8120 Black Ed. (yes I know, will be buying an i5 at some point, but I gotta work with what I have for right now...)
Xigmatek Loki
MOBO ASRock 970 Extreme3
RAM Corsair Vengence 1600 DDR3 running installed properly for dual channeling 2x8GB (this is set for 1333. I have tried running it at both that and 1600)
(I had Vengence 2133 in there previous to this and removed it for the 1600 during the course of testing)
AMD Radeon HD 6770
Thermaltake 750w PSU
Nothing is OCed.

So far I have done the following
Ran CPU-Z/GPU-Z and checked temp and voltage, doubled checked the temp with Speedfan
Un-installed and re-installed the video drivers (Ran Driver Fusion after removal to clean everything out)
Ran Microsoft update
Virus scanned (both on and offline)
Ran Glary Utilities to clean up registry leftovers (multiple times)
disk scan
made sure MOBO/chip/anything else I could think of, drivers were up to date
Ran Secunia PSI in case I forgot something driver wise.
Tried running the games with my sound disabled completely
booted the machine into diagnostic and tried running the games
uninstalled my virus scanner and made sure Windows defender was disabled and tried running the game
Tried Anti-Freeze to see if I could keep from having to hard shut it down.
Lowered the video settings on CO to min.

None of it matters. I will be playing and whether it is 5 mins or 55 mins, the system will just stop.

I have checked event viewer, looked at the diagnostics and other than a standard, (oh hey, you powered off your system!), kernel error, I don't see anything jumping out at me.

Any ideas?