[SOLVED] Games Crash and Textures Load Slow

Aug 30, 2020
2
0
10
0
First off Heres my specs
NVIDIA Geforce GTX 960 2GB
CPU: Intel Core i5-3470s @2.90ghz with turbo to 3.60GHZ
Motherboard: Acer Veriton x4620
RAM: 8GB DDR3 Ram @ 1333MHZ (Going to upgrade this weekend)

I just did a fresh reinstall of Windows and it still didnt help.
Fortnite's textures take about 30secs to a min to fully load in, I also get crashes in every game except bo2 zombies.
CSGO runs fine but about every 30mins to 2 hours the game will crash or BSOD (different error code everytime)
GTA V textures will pop in (not as noticeable cuz open world) But the game will crash after about 5-30mins of playing
The Cycle will crash after about 30secs cuz textures wont load
All these games run off of my WD_Black p10 2TB gaming HDD, dont have space on my 128GB SSD for OS.
I bought this game drive to help fix this issue. I got this pc as a hand me down a week ago, the PC cant be more than a year old(Custom Built)

Please help
 

Desch_

Reputable
Apr 29, 2016
153
21
4,595
12
It sounds like your Motherboard is on its last leg my friend.

The PC is definitely more than a year old. If i were you i wouldnt upgrade that RAM and instead I'd start saving for a DDR4 build.

You can definitely use the gtx 960 and probably the PSU and harddrive in your prospective new build, but a new MoBo, CPU, and RAM would all be necessary.

Also, what harddrive and PSU ru using? Maybe edit original post to include these specs of your build, it could be helpful for troubleshooting.
 
Aug 30, 2020
2
0
10
0
It sounds like your Motherboard is on its last leg my friend.

The PC is definitely more than a year old. If i were you i wouldnt upgrade that RAM and instead I'd start saving for a DDR4 build.

You can definitely use the gtx 960 and probably the PSU and harddrive in your prospective new build, but a new MoBo, CPU, and RAM would all be necessary.

Also, what harddrive and PSU ru using? Maybe edit original post to include these specs of your build, it could be helpful for troubleshooting.
The PC was built about 10 months ago.
Im not sure of the psu ik its a roswill brand.
the HDD is WD_Black p10 2TB gaming HDD, dont have space on my 128GB SSD for gaming i just boot win 10 off of it
i just watched a ton of fortnite benchmarks with this cpu even with a 1050 or a 1660 super the textures dont load well. Im sure its the CPU.
 

ASK THE COMMUNITY