Question Games Crashing at Startup

Mar 27, 2020
1
0
10
0
I have had my computer fro almost 6 years with no major issues I haven't been able to fix on my own. This morning I opened up my computer as normal and tried to open rocket league and the game opened to its first loading screen with the Psyonix logo then crashed. I tried this with a few other games including Doom 2016, Total War Warhammer, Battlefield 5 and Overwatch. All of these games crashed upon trying to open. Some of them would only open to a black screen and I would have to close manually with the task manager. Some of the games will try to send a blank crash report but will not do it every time they crash. I also got this error when trying to open rocket league 1 time "the exception unknown software exception (0xe0000008) occurred in the application at location 0x00007ffa6cc7a859"

The only game on my computer that is working is Sid Meier's CIV 5 which runs completely fine. Also after trying to start a few different games the desktop stops showing what icons are highlighted when clicking on them and this only goes away when the computer is restarted.

I tried uninstalling and reinstalling rocket league to see if that would help and it did not change anything. I have updated my drivers with the GeForce experience as well as updated Windows 10. I also ran a Windows Memory Diagnostic which found nothing. The only thing I did when shutting off my computer last night was uninstall Samsung Magician which I wrongly thought was a bug as it was giving me popups I had never seen. I reinstalled this this morning after these issues began. I have also been using Core Temp to check the temperatures while trying to start the games but I have not seen any changes from regular temps.


My specs are:
CPU: Intel Core i5-6600K
MOBO : Gigabyte Z170N-Gaming 5
RAM : 16 GB (2x8GB) G. Skill Ripjaws V series DDR4-2400
SSD : Samsung 850 EVO 500 GB
GPU : NVIDIA GeForce GTX 1070
PSU: EVGA 700 BR

The only thing I have replaced since building it 6 years ago is the PSU which I replaced about 1 year ago. I have no idea why this is happening. Thanks for your help.
 

ASK THE COMMUNITY