Question Games locked at 60FPS on 144Hz display ?

ethan206

Reputable
Jul 27, 2018
148
1
4,695
1
Hi, I recently just purchased a Razer Blade 14 2021 (RTX 3060 Base Model) and I noticed that it runs at 144Hz, but in games, it's capped at 60. Like, whenever I enter a game, it automatically goes into Windows settings and changes the display refresh rate from 144 to 60 and doesn't change back unless I manually switch it back to 144. This happens both plugged in and on battery. In GeForce Experience, I disabled Battery Boost and WhisperMode and in Razer Synapse, I set it to the max performance mode/144hz, and still whenever I enter a game, it's just locked at 60Hz/fps. I have a suspicion it's something to do with the GPU switching because I think normally when I'm not in a game it uses the integrated Radeon graphics and then whenever I fire up a game/something GPU intensive it'll switch to the RTX 3060 and I guess something in Windows prompts it to switch to 60Hz. Does anybody know a fix?
 
Hi, I recently just purchased a Razer Blade 14 2021 (RTX 3060 Base Model) and I noticed that it runs at 144Hz, but in games, it's capped at 60. Like, whenever I enter a game, it automatically goes into Windows settings and changes the display refresh rate from 144 to 60 and doesn't change back unless I manually switch it back to 144. This happens both plugged in and on battery. In GeForce Experience, I disabled Battery Boost and WhisperMode and in Razer Synapse, I set it to the max performance mode/144hz, and still whenever I enter a game, it's just locked at 60Hz/fps. I have a suspicion it's something to do with the GPU switching because I think normally when I'm not in a game it uses the integrated Radeon graphics and then whenever I fire up a game/something GPU intensive it'll switch to the RTX 3060 and I guess something in Windows prompts it to switch to 60Hz. Does anybody know a fix?
Try to go to NVCP then go to manage 3d settings, and use High performance nvidia processor and apply. Also set the monitor to 144hz in NVCP (if there is the option to) and apply, then try again.
 

ethan206

Reputable
Jul 27, 2018
148
1
4,695
1
Go in to device manager, click on display adapter. If the Amd graphics is listed along with the Nvidia adapter, right click on amd adapter and disable it.
Would disabling it cause any problems? In Windows settings, I noticed that my laptop display was connected under the AMD graphics, so if I disable it, will it automatically switch to using the NVIDIA one all the time? Because, from time to time I would still want to use the AMD one to save battery life on the go, so would I have to disable and re-enable through Device Manager every time?
 

ethan206

Reputable
Jul 27, 2018
148
1
4,695
1
Try to go to NVCP then go to manage 3d settings, and use High performance nvidia processor and apply. Also set the monitor to 144hz in NVCP (if there is the option to) and apply, then try again.
Unfortunately, it didn't work. There wasn't an option to switch to 144hz in NVCP and I switched to use high performance nvidia processor on global settings with no success.
 

ethan206

Reputable
Jul 27, 2018
148
1
4,695
1
Well if it is switching to Nvidia to game then go in to Nvidia control panel, change resolution line, and make sure the refresh rate is set to 144hz
It doesn't give me the option to select 144Hz in NVCP, I think it's because it detects I'm using the AMD one, so I don't have access to additional videos settings through NVCP.

Also disabling the AMD GPU through Device Manager doesn't work either as it just uses the basic Microsoft Display Adapter instead of the RTX 3060 and everything looks zoomed in and the resolution is all messed up.
 
Last edited:

ASK THE COMMUNITY