Question Games look laggy on 144Hz

Jul 19, 2020
7
0
10
0
I already posted similar post but nobody responded.
Since I bought new monitor (I bougt it so I could play games like csgo, valorant, fortnite more smoothly) however games that I can't play in 120-144 fps fells laggy, so if my game is locked on 100 fps it feels like its below 60 and if it's locked on 60 it feels like 30-25 fps. I saw that you need to try to play at least on 72+ fps so it could be smooth. Ok, I thought maybe it's because of motior, so I changed it back to old monitor (60 Hz) and it's a same thing, game on 60 feels like 30. Maybe I got used to 120-144 fps and now 60 feels like it is 30, but I don't think it's that because I rember how games felt before on 60 fps. I dunno, maybe is something with my pc or maybe with monitor. If someone had the same problem and managed to fix please let me know. Also let me know if theres no fix or it should be like this.
PC specs:
GPU: Nvidia GeForce GTX 1650 SUPER
CPU: AMD Ryzen 5 3400G
RAM: 8GB (4x2)
OS: Windows 10 pro
Monitor: AOC C27G1
 

anceintsz

Distinguished
Jul 17, 2012
148
3
18,695
0
I already posted similar post but nobody responded.
Since I bought new monitor (I bougt it so I could play games like csgo, valorant, fortnite more smoothly) however games that I can't play in 120-144 fps fells laggy, so if my game is locked on 100 fps it feels like its below 60 and if it's locked on 60 it feels like 30-25 fps. I saw that you need to try to play at least on 72+ fps so it could be smooth. Ok, I thought maybe it's because of motior, so I changed it back to old monitor (60 Hz) and it's a same thing, game on 60 feels like 30. Maybe I got used to 120-144 fps and now 60 feels like it is 30, but I don't think it's that because I rember how games felt before on 60 fps. I dunno, maybe is something with my pc or maybe with monitor. If someone had the same problem and managed to fix please let me know. Also let me know if theres no fix or it should be like this.
PC specs:
GPU: Nvidia GeForce GTX 1650 SUPER
CPU: AMD Ryzen 5 3400G
RAM: 8GB (4x2)
OS: Windows 10 pro
Monitor: AOC C27G1

Are you using display port or HDMI?
 
Jul 19, 2020
7
0
10
0
I already posted similar post but nobody responded.
Since I bought new monitor (I bougt it so I could play games like csgo, valorant, fortnite more smoothly) however games that I can't play in 120-144 fps fells laggy, so if my game is locked on 100 fps it feels like its below 60 and if it's locked on 60 it feels like 30-25 fps. I saw that you need to try to play at least on 72+ fps so it could be smooth. Ok, I thought maybe it's because of motior, so I changed it back to old monitor (60 Hz) and it's a same thing, game on 60 feels like 30. Maybe I got used to 120-144 fps and now 60 feels like it is 30, but I don't think it's that because I rember how games felt before on 60 fps. I dunno, maybe is something with my pc or maybe with monitor. If someone had the same problem and managed to fix please let me know. Also let me know if theres no fix or it should be like this.
PC specs:
GPU: Nvidia GeForce GTX 1650 SUPER
CPU: AMD Ryzen 5 3400G
RAM: 8GB (4x2)
OS: Windows 10 pro
Monitor: AOC C27G1
Now I tried to connect Ps4 to this new monitor and Call of Duty Advanced Warfare runs in around 60 fps I think and it works perfect without any lag. Maybe it's something with computer, I don't know.
 

anceintsz

Distinguished
Jul 17, 2012
148
3
18,695
0
Now I tried to connect Ps4 to this new monitor and Call of Duty Advanced Warfare runs in around 60 fps I think and it works perfect without any lag. Maybe it's something with computer, I don't know.
Have you tried doing this:

Right-click desktop, go to display settings, at the bottom should have graphics settings, it will say "Classic app" and you select browse.

Find the game exe you're trying to run and select it, then set it on high performance.

There will be an option at the top for variable refresh rate optimization for games that don't support it, turn that off and see.
 
Jul 19, 2020
7
0
10
0
Have you tried doing this:

Right-click desktop, go to display settings, at the bottom should have graphics settings, it will say "Classic app" and you select browse.

Find the game exe you're trying to run and select it, then set it on high performance.

There will be an option at the top for variable refresh rate optimization for games that don't support it, turn that off and see.

Unfortunately it didn't work, but thanks for trying to help me.
 

ASK THE COMMUNITY

TRENDING THREADS