Games not running well on GTX 670, or on replacement GTX 680, help?


Apr 16, 2009
Okay, so I'll give as much info as I can on this for the moment, as it's not my PC, it's a friend's, but he recently built a PC, and for a couple month's he's been complaining about low FPS in games that he didn't think he should be getting, and frankly, I didn't either, as he was using parts that should be plenty good enough.

Anyway, one example is in Borderlands 2, with maxed out settings, when launching the game, and at the main menu, he won't break 20FPS. Most of the time during start-up it's 10-15FPS, and then once he's on the main menu, it stays around 15-20FPS.

This is with the newest NVidia Drivers installed, and with both his old GTX 670, and the new GTX 680 he just bought to replace the GTX 670 and see if it would fix the problem.

This of course shouldn't be the case, as I know someone else with a GTX 670 that has it maxed, and hits 60FPS all the way through launch and constantly at the main menu, and I myself have a GTX 680, and hit 60FPS all the way through as well.

His computer specs currently are:

GTX 680
Intel i7-2700k
8GB's 1600MHz RAM
7200RPM WD 500GB Hard Drive

I don't exactly remember the motherboard, it may have been a Sabertooth, and I'm also unsure of the PSU.

I can't be hands on at all with the computer, as he doesn't live near me, but I'm just trying to find out if anyone has any idea what could be the next step, since it could be so many different problems.

From TeamViewer I checked, and watched his 670 performance, and told him as far as that went, everything looked fine, but he still went ahead with the upgrade to the 680, and is still having the same problems, and again, I checked, and it looks to be running as normal.

I know there's a lot of other things that can be causing the problem though, and he really has no way to exchange parts, or test anything.

Are there any steps I could have him take, to help find out what the problem may be?

go into bios and load optimized defaults.
then go check the pci-e is set to peg mode 1 (if the card is connected to the first pci-e slot) and its running at x16, you may want to turn off hyperthreading in bios or if he leaves it on that he sets 8 cores in msconfig in windows. if its set to 4 then it will only use 2 cores with hyperthreading enabled meaning he will gimp his cpu.