[SOLVED] Games stuttering after installing a new GPU

Trax00

Commendable
May 20, 2017
33
1
1,545
1
So what i'm experiencing is my games stutering ever since i got my new GPU
For example: With my old GPU i could run bioshock infinite and play for a few minutes before it eventually freezes or crashes,but with the new one MSI afterburner shows ~90fps on med/high settings and i get stutters
I also noticed that the "loading circle" keeps flashing on my mouse cursor ever since installing the new GPU drivers
I'd like to mention that before swapping my GPUs,i forgot to uninstall the drivers from the old one,and i don't know if that creates an issue since i switched from Nvidia to AMD
Any help is appreciated

Components (It's a wild ride)
Corsair 350W (No clue what the model is)
AMD Phenom II X4 945 (Quad core @ 3.00Ghz)
RAM 8GB DDR2 800mhz (From kingston)
Gigabyte GA-M56S-S3
Old GPU:Nvidia Geforce 9800GT (Gainward)
New GPU: AMD Radeon R9 270 (Powercolor)
 

Trax00

Commendable
May 20, 2017
33
1
1,545
1
I just wanna say thanks to drivinfast247 and TLGalenson for the answer,since i don't think i can set them both as the correct answer
Solution that worked for me:
I used DDU to remove the old Nvidia card drivers,then rebooted,after that i cleaned out the current AMD drivers,and rebooted,after that i installed AMD drivers from September,then rebooted
After that i noticed that the Radeon Software process was not running and eating up 20% of my cpu,(Also for the installation i chose to not install ReLive as i heard it has some issues)After that i ran Bioshock Infinite still in windowed,and noticed no stutters,i switched to Fullscreen and the FPS was capped at 60,not going below while going through some areas,so that's a plus,i also checked warframe (As for some reason the Earth planet was a huge issue for me and lots of other players,also Plains of Eidolon ("Open world'ish map")) And that worked PERFECTLY,the CPU usage went to about 90%,but the FPS remained at 60,as it was capped in the settings.
Sorry for the long explanation,but these guys helped me fix the issue i had
AGAIN,BIG THANKS TO drivinfast247 AND TLGaleson!
 
Reactions: drivinfast247

TLGalenson

Reputable
Nov 19, 2016
17
1
4,510
0
Try an older AMD driver (6 months or a year or more). I hope your card doesn't need the very latest driver which sometimes are buggy.
I had to run an older driver on an Amd 2400G (Apu) so you might need to too.

Tom (no relation)
 

Trax00

Commendable
May 20, 2017
33
1
1,545
1
Try an older AMD driver (6 months or a year or more). I hope your card doesn't need the very latest driver which sometimes are buggy.
I had to run an older driver on an Amd 2400G (Apu) so you might need to too.

Tom (no relation)
I can't figure out where to find older drivers,

Also: I've noticed that my HDD usage keeps spiking hard,from 0% on desktop to 90%,and just keeps doing that,i ran bioshock infinite today with 80 FPS without stuttering but in windowed mode too,so i really have no clue what could the issue be
 

CosmicDance

Upstanding
Jun 11, 2019
365
73
390
26
Looks like your PSU is way too weak -


Andy
 

Trax00

Commendable
May 20, 2017
33
1
1,545
1
I just wanna say thanks to drivinfast247 and TLGalenson for the answer,since i don't think i can set them both as the correct answer
Solution that worked for me:
I used DDU to remove the old Nvidia card drivers,then rebooted,after that i cleaned out the current AMD drivers,and rebooted,after that i installed AMD drivers from September,then rebooted
After that i noticed that the Radeon Software process was not running and eating up 20% of my cpu,(Also for the installation i chose to not install ReLive as i heard it has some issues)After that i ran Bioshock Infinite still in windowed,and noticed no stutters,i switched to Fullscreen and the FPS was capped at 60,not going below while going through some areas,so that's a plus,i also checked warframe (As for some reason the Earth planet was a huge issue for me and lots of other players,also Plains of Eidolon ("Open world'ish map")) And that worked PERFECTLY,the CPU usage went to about 90%,but the FPS remained at 60,as it was capped in the settings.
Sorry for the long explanation,but these guys helped me fix the issue i had
AGAIN,BIG THANKS TO drivinfast247 AND TLGaleson!
 
Reactions: drivinfast247

ASK THE COMMUNITY

TRENDING THREADS

Latest posts