Question games stuttering if i dont minimize programs in background

Feb 15, 2020
12
0
10
0
Hello, i've experience really weird problem on my new pc thats like week~ old. So basically whenever i play games in fullscreen with uncapped fps and i have some programs running in the background, like discord, chrome, obs or other games for example, my game will start stuttering... or like skiping frames id say? its not actual fps drops or xseconds/ms freezes but constant, i dont even know what to call it... microstutters? Although the fps are still high it just feels like id be playing on 30fps and really low mouse sensivity. heres example of what it looks like :
View: https://youtu.be/9WRxBylcTs8
(the first part is with the stutters and then without, its hard to notice with the clips being in 60fps but i slowed a part down so its easier to spot) So yeaa... the moment i minimize the other programs before going into fullscreen everythings fine. I dont know what can be causing it. Temperatures are really low like 40-60c, cpu/gpu usage doesnt go above like 70-80% and like 50-60% for ram... resource monitor doesnt seem to find any specific task that would be causing hard faults or w/e, i ran multiple device tests which ill list below but they also seem to work, updated all my drivers with the driver boost thing and optimized my ssd, maybe someone would be able to help me cause its really annoying to have minimize everything everytime i alt tab out and in etc. especially when im streaming... and im running out of ideas on how to fix it.

my pc specs:

Operating System
Windows 10 Home 64-bit
CPU
Intel Core i7 9700k @ 8x 3.60GHz 12MB L3-Cache
RAM
16,0GB Corsair Vengeance LPX DDR4-2666 / 2x 8GB
Motherboard
ASUS ROG STRIX Z390-F GAMING / Intel Z390
Graphics
LG FULL HD (1920x1080@60Hz) - only one monitor
NVIDIA GeForce RTX 2060 6GB MSI Gaming Z
Storage
2TB Seagate BarraCuda Compute
500GB Samsung 860 EVO SSD
Power Supply
700W - be quiet! Pure Power 11
Cooler
Corsair H60 v2 120mm

RAM test: View: https://imgur.com/8WhW4vV

memory usage when playing: View: https://imgur.com/yXX02CQ

disc scan: View: https://imgur.com/xdJT8T7
View: https://imgur.com/h6TFAez

drivers: View: https://imgur.com/i91ReLq

also removed all the junk etc with cc cleaner

i have no more ideas on what to do please help :c
 
Remove Driver Booster!!! You now probably have older or incorrect drivers installed. Try updating ALL drivers by downloading the correct files from the manufacturer. Also, make sure your BIOS is updated to the latest version.

Make sure the RAM is installed in the correct slots a2-b2.

Or make sure there's no issues and wipe and reinstall Windows completely. Then download and install the correct drivers.
 
Feb 15, 2020
12
0
10
0
Remove Driver Booster!!! You now probably have older or incorrect drivers installed. Try updating ALL drivers by downloading the correct files from the manufacturer. Also, make sure your BIOS is updated to the latest version.

Make sure the RAM is installed in the correct slots a2-b2.

Or make sure there's no issues and wipe and reinstall Windows completely. Then download and install the correct drivers.
Are you sure? it shows me the same thing if i check in the auslogics driver reviver or however its called. how am i supposed to know otherwise if the drivers are correct or not? is there any other software to do it properly or? Also im not really an IT spec so i cant really check myself the ram part, but ive ordered this pc already built from quite big company so i dont think theyd make mistakes in montage but idk
 
Feb 15, 2020
12
0
10
0
do you really need 300 fps on 60hz monitor?
Yeah ik in most games it doesnt make a difference but the game on that clip black desert online has such a weird engine that the more fps you have the shorter animations of abilities you have, which equals more dps. ik it sounds dumb but its really important for me
 
Feb 19, 2020
55
7
35
1
Did you Turn off Windows Game Bar? PA/Kakao will tell you to do a clean install of windows and drivers.
I used to have the same issue on my turing cards, until I got rid of game bar. Also I have seen the same issue on some PC's with RGB software installed, like Mystic light aura sync, and awcc, etc... Discord can also cause this problem with BDO on some systems I have seen. I have also had this issue when I forget to turn off my crypto miner when playing BDO; since it has its own crypto miner built in, it doesn't play well with other crypto miners. BDO is the only game affected by this, and I'm still working on actually finding how they have hidden the miner since they were last caught, lol.
 
Feb 15, 2020
12
0
10
0
did you remove driver buster from your computer as was suggested in a previos post? make sure you have the latest driver for your GPU. if what they are saying is right driver buster may have installed older drivers
Yes i did uninstall driver booster, and used a DDU to uninstall my gpu drivers and installed new ones straight from nvidia website, didnt help.

Did you Turn off Windows Game Bar? PA/Kakao will tell you to do a clean install of windows and drivers.
I used to have the same issue on my turing cards, until I got rid of game bar. Also I have seen the same issue on some PC's with RGB software installed, like Mystic light aura sync, and awcc, etc... Discord can also cause this problem with BDO on some systems I have seen. I have also had this issue when I forget to turn off my crypto miner when playing BDO; since it has its own crypto miner built in, it doesn't play well with other crypto miners. BDO is the only game affected by this, and I'm still working on actually finding how they have hidden the miner since they were last caught, lol.
Yes I did turn win game bar off, also did send a ticket to Pearl Abbys before since i thought its only related to BDO. Thats what their answer was: View: https://imgur.com/jngaAG2
I already did all of the things they suggested too.
As for the RGB programs, i actually think i might have one installed, Its called AURA, should i remove it? And no im not using any crypto miners :/
 

ASK THE COMMUNITY