Question Games won't run on GPU

Jun 4, 2020
4
0
10
0
I've looked up multiple solutions to this issue including: changing display settings to use gpu for specific exe files, and changing the OpenGL Rendering GPU to be my 1070 Ti instead of auto detecting. None of these have worked in the slightest. Instead, games will use my CPU for all of the processing, completely ignoring the GPU and causing my computer to overheat constantly. As you can see in the picture, the GPU is being used for certain processes so I don't think it's installed incorrectly but for some reason it just won't work for games. Occassionally, it'll show up working at 1% power or lower for the game and the GPU engine will say "GPU0 copy" or something like that but that usually only lasts for a few seconds. If anyone has any clue why this is happening, please let me know.
 
Jun 4, 2020
4
0
10
0
What Powersupply?

You have both 8 pin power connectors plugged into it correct?
oh sorry idk why i thought you said processor, my PSU is
Seasonic FOCUS Plus 650 Gold SSR-650FX 650W 80+ Gold ATX12V & EPS12V Full Modular 120mm, whatever all that means. Also, the RGBs on the GPU are working so I'm guessing that it's connected correctly but I'm not sure if I need to go inside and check
 
Task Manager isn't a perfect indicator of GPU usage, try using MSI Afterburner on-screen display. Some games stop using GPU when you alt-tab out of them (I think), so afterburner's OSD will help you see accurate GPU usage.
 
Jun 4, 2020
4
0
10
0
Task Manager isn't a perfect indicator of GPU usage, try using MSI Afterburner on-screen display. Some games stop using GPU when you alt-tab out of them (I think), so afterburner's OSD will help you see accurate GPU usage.
ok so I'm not sure if this is good or bad, the voltage says 0mV, but after starting up COD, the gpu starts heating up so it seems like it's using the GPU as far as I can tell.
 

ASK THE COMMUNITY

TRENDING THREADS