Question Gaming Laptop used to be capped at 60FPS w/ NO VSYNC or any frame capping. Now Its not capped at 60 and super laggy

Feb 11, 2019
3
0
10
0
my msi gaming laptop has always been capped a 60fps since the beginning. I did have 1 screen tear line that was barely noticeable so I didn't care for it. All my games were capped and it ran perfectly and smoothly because I don't need to go higher than 60fps on a 60hz monitor. Recently I had a windows update and I think it changed somethings. Now all my games aren't capped anymore and its unlimited which I don't mind but its the fact that everything is super laggy now. Its super jagged and laggy and every time something graphically intensive happens on screen, its drops form 250fps to 20fps and goes back and forth. I need help to put it back into it place please. I don't want to sue v sync because I don't care about the tearing and I don't want input lag I just want my smooth game play back.


MSI Laptop: https://www.amazon.ca/GL73-8RC-049CA-i7-8750H-GTX1050-keyboard/dp/B07BLCGY6C
 

shknawe

Respectable
Oct 22, 2016
1,288
44
2,490
86
I would go into device manager and make sure your nvidia card is enabled and your primary gpu and not your cpu. Then I would go in to display and under advanced settings make sure your monitor is set at the proper mhz. Make sure your Nvidia drivers are up to date and double check on the Nvidia control panel settings.
 
Feb 11, 2019
3
0
10
0
I did everything you told me to do. Idk how to set my gpu to primary but since all my games are excelling in high FPS. Im guessing its still using my GPU
 
Feb 11, 2019
3
0
10
0
I would go into device manager and make sure your nvidia card is enabled and your primary gpu and not your cpu. Then I would go in to display and under advanced settings make sure your monitor is set at the proper mhz. Make sure your Nvidia drivers are up to date and double check on the Nvidia control panel settings.
I realized in less intensive game it uses my intergrated graphics. I want it to only use my Nvidia GPU
 

shknawe

Respectable
Oct 22, 2016
1,288
44
2,490
86
in device manager go to nvidia gpu and right click enabled. Go to cpu graphics if it shows and right click disable. That should tell the laptop to only use your gpu. Under system in windows check display, under advanced graphics check your adapter setting to make sure it show the Nvidia gpu.
 

Similar threads


ASK THE COMMUNITY