Question gaming pc acting weird and shut down after 25mn of gameplay


Feb 11, 2017

i'm having big issue with my computer lately,
for exemple: i start Shadow Of War i play 5mn and then the pc is acting up like opening geforce experience,windows setting,control panel,speech recognition,notification tab all by itself in-game(not all at once though)so i close it and then another one opens every 5-10mn and then around 20 to 30mn of gameplay the pc shut down but the lights and fans are still working for 15sec and then it completely shut down,so i do nothing and then it restarts and when i am on the windows session screen i enter my password and i find myself back in Shadow Of War like nothing happened.(it does it in every games)
i can play for another 10-15mn and then this time it shut down completely and i need to restart it was working fine from january 2019 to end of july 2020

so what i did:
-reformated the pc with a clean install of windows 10 2004 and then i thought it might be the windows update so i rolled back to the 1909 update.format and clean install again with no avail.
-i rolled back the graphic driver as well back to april when everything was working fine and it changed nothing so i dled the last one and nothing eiher.
-i RMA my rtx 2080 for testing and it works perfectly fine on their systems.
-i bought and tested with a low end graphic card(geforce gt 710) to rule out a faulty PCIE slot,and here everything is working fine i can play for hours and no windows opening in-game or weird crashes.
-tomorrow i receive a new PSU 80+titanium 850w so i'll know if it's the PSU or not.
-when the hdmi is plugged into the MB with the intel UHD graphic 630 everything is working fine as well with no bugs whatsoever.
-my temps are fine CPU is around 60-65° and GPU 65-75° max in-game.
-i'll change my thermal paste tomorrow as well just in case
-i also tried my ram 1 stick at a time and it changes nothing,and the test on my ram with OCCT is ok.
-i did test with OCCT for the graphic card and no errors detected.
-i tried benchmark on Unigine Superposition but it's not long enough so i tested game mode on Unigine Superposition and it bugs after 30mn.
-i updated the bios to the most recent update and it changed nothing.

my pc specs:
-MB Asus ROG Maximus XI Code Z390
-processor: i9 9900k at 4.7ghz and tried without the turbo mode at 3.6ghz and it's the same(no overclocking)
-GPU: RTX 2080 MSI gaming x trio(no overclocking)
-Ram G Skill Trident Z Royal 32gb 3200mhz 4x8(no overclocking)
-PSU seasonic Prime TX-850w 80+ titanium(not tested yet)actual PSU is a cooler master 850w from 6 years ago(with bitfenix cables)80+gold i think.
-AIO NZXT Kraken X52
-NVME M.2 samsung 970 evo 500go
-SSD sata crucial 1to
-7 fans corsair LL 120mm

i really hope someone will be able to help me because i haven't been able to play for 2 months and it's starting to become really annoying.

thanks in advance for any helps :)


Feb 11, 2017
Hello, and thanks Ralston 18 for your reply.

yeah after the weird reboot when i'm back in the game there is a MB error code 30(don't know what that mean though)

Event Viewer i don't know i've never used it.

as soon as i receive my new PSU i'll install it and test again.

thank you.