Question Gaming PC not performing as it should

sakiboskov

Prominent
Jan 2, 2019
5
0
510
0
Hello,
So in August I upgraded my CPU (going from Ryzen 5 1600 to R5 2600). I bought that CPU without cooler so I used my 1600 cooler that I had before (it's an AMD stock cooler). I also got M.2 SSD 250GB but I don't think the issue is in the SSD. The problem is that PC is not performing as it should. When I had 1600 and playing a game where I would have 60+ FPS, it would feel very smooth, but now with 2600 it doesn't feel the like it's 60+, it feels like it's 40-high 40s. I also noticed that when I play a game and alt tab to task manager, my CPU and GPU percentages are quite low (30-50% both). I did a clean install of my GPU drivers...didn't help. Updated windows...didn't help. I tested GTA Online on my 2nd PC which has GTX 1050 and that old 1600 and got much more stable and smoother experience than on PC which has R5 2600. It's like the screen is tearing on 2600. But at the end it might not be the problem with CPU.
PC specs:
CPU: AMD Ryzen 5 2600 (stock)
GPU: AMD Radeon RX 580 4GB
RAM: 2x4GB 2666MHz
MB: Asus A320M-K
PSU: Gaming Falcon 600W
Sorry if my english is not that good.
Hope you can help me
Thanks in advance :)
P.S I updated my bios to the newest version and I did a fresh install of OS
 

sakiboskov

Prominent
Jan 2, 2019
5
0
510
0
Bios version is 5603. Temps are around 60 for CPU and 70 for GPU. Also usage in task manager seems to be inaccurate cause I opened AMD software and saw that GPU is at 90-100% and CPU around 50%
 

ASK THE COMMUNITY

TRENDING THREADS