Question Gaming PC restart

Feb 14, 2022
11
2
15
0
Hi all,

I am reaching out to you all with a problem I cannot seem to solve. I like to game in my free time and it seems that my new PC cannot play certain games. What happens is, it will launch and as soon as it has launched my pc will restart (no blue screen). It only happens with "war thunder" and "ghost recon: wildlands". I can successfully play "overwatch", "CSGO", "skyrim", "RD2", "subnautica", "watchdogs", "diablo 3", "farcry4", "raft" and many more. I can also run Heaven benchmark and cinebench without issue. I have done a powertest with OCCT for an hour. I have done a memory diagnostic with no issue. I don't understand why it seems to be just these two games. When this happens the windows event log states a "Kernel-Power" critical error 41. My understanding is that war thunder might have some issues with Nvidia cards, but not sure about this and I have no idea why ghost recon acts this way. Temperatures never exceed 60degC for either CPU or GPU usually around 55 - 58degs, so overheating doesnt seem to be it either.

My newly built PC has the following specs:

OS: Win 10 pro x64
motherboard: MSI B450 GAMING PLUS MAX
ram: Corsair Vengeance LPX 32 GB - PC4-21300 - DIMM
CPU: AMD Ryzen 5 5600X
GPU: Gigabyte AORUS GeForce RTX 3060 Elite 12G (rev. 2.
PSU: Seasonic Focus GX - 850W

games that do not work:
War thunder
Ghost recon: wildlands EDIT:(going to steam directory and running GRW.exe as administrator makes it work, running straight from steam cause crash (even is steam is run as admin))

games that work:
rust
overwatch
diablo 3
crysis 3
dragon Age origins
CSGo
watchdogs
subnautica
Reddead remption 2
raft
farcry 4
sims 4
skyrim
minecraft
frostpunk
arma 3
gary's mod
dota 2
 
Last edited:
Feb 14, 2022
11
2
15
0
Go into your device manager and see if any devices need driver updates. Especially your gpu and sound card. There may be a driver those two games need or do not like.
Thanks for your reply. I checked the device manager and nothing seems to be out of date. I use the geforce experience software to keep my GPU up to date.

I use the Realtek High definition audio driver v. 6.0.9071.1
And the Nvidia game ready driver v. 511.79
 
Feb 14, 2022
11
2
15
0
Do you use Msi Afterburner?
Yes I do have MSI afterburner, but not using it to overclock (I have no overclocks running). Settings are:

core voltage: +0%
power limit: 100%
temp limit: 83C
core clock: +0
memory clock: +0
fan speed: 100%

I will try to run the driver uninstaller and then how do you propose to install the driver, straight from Nvidia site or using the windows driver updater?
 
Ok so try this first, on the Afterburner panel, near the fan slider, there will be a half circle arrow, click on that, it will rest the settings on gpu to normal. Click on the check mark to keep the settings. You can keep the fan at any speed you like. See if this helps at all.
 
Feb 14, 2022
11
2
15
0
Ok so try this first, on the Afterburner panel, near the fan slider, there will be a half circle arrow, click on that, it will rest the settings on gpu to normal. Click on the check mark to keep the settings. You can keep the fan at any speed you like. See if this helps at all.
No it didnt work. I clicked the rotating arrow and clicked the checkmark (all it did was reset my fan speed to "auto") tried to launch WarThunder and as soon as the initial loading screen finished my PC restarted.

I started my pc in safe-mode and used the DDU to uninstall all graphics drivers, went to the nvidia site and downloaded the driver for my GPU (without installing geforce experience) no luck.

What I have noticed is that if I am quick enough after the restart I can get into the game, but alt-tabbing then makes my pc restart. If I have left my PC alone for 5minutes then it will restart as soon as the initial loading screen is done (before entering the full-screen loading screen). I have run malwarebytes and found nothing (just incase I had a virus or something)
 
Feb 14, 2022
11
2
15
0
No it didnt work. I clicked the rotating arrow and clicked the checkmark (all it did was reset my fan speed to "auto") tried to launch WarThunder and as soon as the initial loading screen finished my PC restarted.

I started my pc in safe-mode and used the DDU to uninstall all graphics drivers, went to the nvidia site and downloaded the driver for my GPU (without installing geforce experience) no luck.

What I have noticed is that if I am quick enough after the restart I can get into the game, but alt-tabbing then makes my pc restart. If I have left my PC alone for 5minutes then it will restart as soon as the initial loading screen is done (before entering the full-screen loading screen). I have run malwarebytes and found nothing (just incase I had a virus or something)
I bought a new 2TB ssd that I will install a fresh windows copy on, will update if that works. Currently I use a SSD for OS and a WD black HDD with my steam folders. I transferred these drives to the new PC when these glitches started happening. Maybe a fresh copy of windows will help.
 
Reactions: Fix_that_Glitch
Feb 14, 2022
11
2
15
0
Nope, unfortunately did not fix the issue. I'm guessing its not HW related issue because it is only happening with these two games and nothing else. Based on that can we rule it out or is it still potentially HW related?
 
Feb 14, 2022
11
2
15
0
So we will go with just the games as the problem... Have you tried running the games as administrator, verified the files integrity in steam, reinstalled the games and changing windows power settings?
I'm still waiting on the new SSD to arrive (tomorrow). The afterburner/Rivia tuner turn-off didnt work.

I have verified the integrity using steam. I uninstalled the programs (and deleted the remaining folders in the steam folder), I changed my power settings to high and not letting the disk go to sleep. I will try to run both steam and uplay connect as admin to see if that makes a difference.
 
Feb 14, 2022
11
2
15
0
Have you run sfc /scannow in powershell?
Running it now. *Edit -> no issues found

I went to the steam directory for GRW and ran GRW.exe as administrator and it works like a charm......... I forgot my login credentials for war thunder so need to reset that and try running it straight from the directory as administrator.

If this solves it.... is there a way to just let me run everything as administrator cause..... its my pc.....
 
Feb 14, 2022
11
2
15
0
Running it now. *Edit -> no issues found

I went to the steam directory for GRW and ran GRW.exe as administrator and it works like a charm......... I forgot my login credentials for war thunder so need to reset that and try running it straight from the directory as administrator.

If this solves it.... is there a way to just let me run everything as administrator cause..... its my pc.....
Update: I can actually play the game when run as admin, but if I alt-tab during a loading screen or during start-up it will still reboot.
 
Feb 14, 2022
11
2
15
0
Ok I found out what the problem was. Both GRW and WT use "easy anti cheat". I did a bios update to the one that was released 20-1-2022 and now it seems the issue is resolved. I found this out when launching WT through the launcher where it had a tickbox for the easy anti cheat. Without it checked it ran like a charm, with it checked it would cause the restarts on launch.

@Fix_that_Glitch thanks so much for your help!
 
Reactions: sholzy

ASK THE COMMUNITY

TRENDING THREADS