Gaming PC slower network than laptop!

Crazygoldfish

Honorable
Apr 30, 2012
18
0
10,510
0
Hello,

I am completely stumped.

Was previously on Virgin UK vivid 250 which gave me around 200-250 Mbps & 10 up.

Upgraded to vivid 350 & noticed my gaming pc gave me the same down speed but 20 up.

So I connected my old laptop to the same Ethernet cable and got 384down and 22 up.

The pc is built by myself and all latest drivers. Tried a few cables and every time the pc is 200 down and laptop around 360-380.

The motherboard is a gigabyte z270x ultra gaming board.

Struggling with what to try next,,,,, any ideas?
 
Lets try changing several things, which could be causing the slow speed.
Perform an internet speed test after each adjustments to see if improve your internet speed

-If you haven't connect the network cable to another port in the router.

-Go to Device Manager
Expand Network adapters, right-click the Network Interface Card, select Properties then click the Advanced tab.
Check that Auto Disable Gigabit is set to Disabled
Make sure that Speed & Duplex is set to Auto negotiation or 1.0 Gbps Full Duplex.
Make sure the Receive Buffers is 512

-Also turn off the peer to peer update process on your PC.
Go to Settings and select “Update and Security“.
Click the “Advanced Options” tab.
Click the option “Choose How Updates are Delivered".
Turn off the On button.

-Shut down the peer to peer update process on your PC. That is to say, you need to close the channel which you can download applications and system updates from other PC’s connected to the server since it limits your internet bandwidth seeding to other users.

-Windows might reserve a chunk of the bandwidth for the OS.
Press the Win + R keys to open Run dialog box.
Type gpedit.msc and then hit OK.
A pop-up window will open with title of Group Policy.
Click on Computer Configuration on the right side of the window.
Navigate to: Administrative Templates -> Network – > Qos Packet Scheduler – > Limit reservable bandwidth.
Click on Enable.
Change the Value from 20 to 0.
Apply and then click OK. Reboot

-Disable Windows 10 Auto-Tuning
Press Win + X keys and select Command Prompt (Admin).
Type the command netsh interface tcp show global in the window.
Check for Receive Window Auto-Tuning Level and if it is normal, you will need to disable it.
Type the command netsh int tcp set global autotuninglevel=disabled to disable it.
To re-enable the Window Auto-Tuning level by typing the command netsh int tcp set global autotuninglevel=normal in the Command Prompt (Admin).

-Try updating from Windows 1803 to 1809. 1803 has a bug that could cause slow internet speed on some systems.
 

Crazygoldfish

Honorable
Apr 30, 2012
18
0
10,510
0


Ok will try and get back to you later

 

Crazygoldfish

Honorable
Apr 30, 2012
18
0
10,510
0


ok the only thing i didnt do was this

Check that Auto Disable Gigabit is set to Disabled

As i couldnt see it in the adapter settings.

Got a small increase from average of 190rish to 212ish, but still no where near the laptop or other devices.

I also updated the router which is a netgear xr500, and made sure that there were no limits or bandwidth throttle for my gaming pc ip.
 
Which antivirus do you have? Turn off its firewall and see if the speed improves.
I would try different drivers.
Perform a visual inspection on the Ethernet port on the motherboard, in case there is a broken or misaligned pin.
I have received motherboards with faulty or broken Ethernet port.
 

Crazygoldfish

Honorable
Apr 30, 2012
18
0
10,510
0


its not hardware related...... I installed windows 10 onto an external usb drive so i could test the same hardware from a fresh build of windows.

got full speed.

went back to normal build and its bag to slower speeds. I will just reset windows and bite the bullet


 
I'm glad you did.
Is your Windows 10, an upgrade from a previous version?
Windows 10 has those optimizations built-in, unless it gets upgraded from a previous version of Windows or an app changes those setting.

 

Crazygoldfish

Honorable
Apr 30, 2012
18
0
10,510
0


No it was a windows 10 install from iso about 2 years ago

 

ASK THE COMMUNITY

TRENDING THREADS