Question GC-Titan Ridge with 2 RTX 2080 Cards

Apr 18, 2020
2
0
10
0
Z390 AORUS MASTER(rev 1.0)
BIOS Version F11c
i9 - 9900K
32GB RAM (4X8)
2 - EVGA RTX 2080
GC-Titan Ridge (TBT Controller)
1 SSD SATA Drive

The system works great without the TBT card.

When I add the TBT card, I get no boot/video trying all of the video ports, including onboard. BIOS video output is set to the card in PCIe slot 1 (one of the 2080s).

If I remove one of the 2080s from the PCIe x8 (Slot 2), leaving a 2080 in the PCIe x16 (Slot 1) and the TBT card in PCIe X4 (Slot 3) - the system posts and I can go into the BIOS and set up the TBT support and when the system boots, Win10 sees the TBT Controller and anything I plug into it. Almost there!

As soon as I add the second 2080 back into Slot 2, powering on the system produces no boot and no video to show me the status of the BIOS, Post, or boot.

LCD Error code on the MB is A6 (Detect and install all currently connected SCSI devices).

SATA drive works fine (See working configs above).

I have tried moving the SATA cable to different connectors, but I have the same result.

I do not have any M.2 components installed.

Any idea why the system cannot move past having all 3 PCIe slots occupied? Where do I even start?

Thank you.
 

ASK THE COMMUNITY

TRENDING THREADS