[SOLVED] Geforce RTX 2080Ti - Power Save Mode/Display Adapter Not Detected

Jan 2, 2021
4
1
25
1
Hello all,

Recently, I was playing Call of Duty: Warzone, and experienced a series of game crashes (did not get a DEV ERROR code; certain there should have been one, but never got the dialog box to show). I built my PC in May of this year, and never experienced as many crashes as I did in the one day (it was 4 crashes in a matter of 3 hours). I once started the game in safe mode and reset all graphics settings, re-tuned, but then experienced what I am referring to as the catastrophic failure. My GPU fans spun to 100% (sounded like 110%), my display went black and sound froze with the last soundbite (slide canceling in game), and both of my monitors (one HDMI with discord, etc. and one DP for game screen) entered into Power Save Mode. Any time I boot the PC with the GPU installed and display cables hooked up, it will boot with sound, but monitors will enter Power Save Mode.

I have relentlessly browsed these forums for troubleshooting tactics, and have performed the following actions with no results:
  • Unplug both display cables and re-seat them
  • Try only HDMI cable
  • Try only DP cable
  • Updated MOBO Bios
  • Remove GPU from PCIe slot and re-seat
  • Unplug 8+8 power supply cable and re-install
  • Remove GPU from desired PCIe slot and install in different slot
  • Attempted to downgrade GPU drivers, but unable as device not detected (as described below)
I do not have another GPU to try at this time, as I gave my previous card to my little brother for Christmas.
I have noted a few things during my troubleshooting listed below:
  • Plug HDMI cable into MOBO graphics port; system will boot and display is present
  • When booting the system with GPU installed and any display cable attached, MOBO stuck at "VGA" LED indicator
  • With GPU installed but no display cable installed, booted system with HDMI plugged into MOBO port. Once booted, opened device manager and GPU not detected.
  • Read that, without a display cable plugged in, GPU may not be detectable as it is not 'active.' Plugged in HDMI/DP cables, but still not detected in device manager.
At this stage, I'm at a bit of a loss unless I can find a spare GPU to try out from a friend. However, I have listed my hardware below for reference, and am essentially prepared to start the RMA process for the GPU unless someone wise here can assist.

CPU: i7 9700K
GPU: Geforce RTX 2080Ti OC 11GB
Storage: Samsung SSD 860 EVO 1TB, Samsung SSD 860 EVO M.2 250GB
MOBO: ASUS Prime Z390-A
RAM: Corsair Vengeance RGB PRO; 2x8GB DDR4 3600MHz
PSU: Corsair RM750X
Case: NZXT H710

Thank you!
David
 

ASK THE COMMUNITY

TRENDING THREADS