Generic PnP Monitor Issue: Asus VG278HE 144hz with GeForce RTX 2080 TI

Jan 4, 2019
1
0
10
0
Hey all...

I have been sinking hours into this and its just not making sense to me. A few years ago my girlfriend got me the Asus VG278HE which was my first 144hz monitor. My old machine (Windows 10, GTX 970) recognized the monitor and I was able to set it to 144hz, no drivers or anything and everything worked properly.

Fast forward to now and I just built my dream machine, but the monitor keeps reading PnP so I can't force set to 144hz. I checked the Asus help site and there does not exist a driver for that Monitor for Windows 10. There is a driver for Windows 7/8 but if I run the installer it "can't find any hardware".

I understand that maybe the monitor simply does not work with this Graphics Card and its current driver (which is up to date).

I wonder if there is a way to set monitor settings manually to be over written?

I don't understand if the issue is my monitor not having a driver, my graphics card, or my graphics card driver(which is current) not having support for the monitor, or something else entirely.

I am a software developer and I ask one of the older devs if he had any ideas. He told me I could plug the monitor into the old machine and look up the .dll that is associated and then copy that and its dependancies to a new machine. This is a good idea, but the old machine is 2.5 hours away (I gifted it to family) and I really don't want to have to drive that with my monitor just to get a driver if there is a way to fix it.

Card: NVIDIA GeForce RTX 2080 Ti - 11GB - GIGABYTE GAMING OC (VR-Ready) - Single Card
Cable : Display Port

Any ideas or help would be much appreciated!

- Sadwolfe
 

Dunlop0078

Polypheme
Herald
It shouldn't need a driver to display at 144hz, my asus PG279Q will do 144hz with or without it's driver installed. Most monitor companies have no drivers at all for their monitors, they just use the generic windows driver.

Usually when I see that someone cant set 144hz on a monitor that supports it is because of the cable or they do not have their GPU drivers installed.

Have you tried changing the refresh rate in nvidia control panel?
 

ASK THE COMMUNITY

TRENDING THREADS