Question Genshin Impact Framedrop below 60 but GPU/CPU usage at 60%?

Sep 21, 2021
1
0
10
0
Here a video of the issue:
View: https://www.youtube.com/watch?v=AaNvqcmgL0k


My GPU/CPU usage is abour 60-70% and Vram at 2500.
I am not sure why my fps flactuates between 50-60

Vsync is turned on and i am using a 60hz display.

My system:
GTX 980
I7 4790k @ 4,6ghz
16gb DDR3 Ram (1600)
Samsung Evo 860 SSD

The PC has been Formated a week ago:
I have the newest Driver and flashed my bios to its newest version.
However it did not help.
 
Last edited:
Here a video of the issue:
View: https://www.youtube.com/watch?v=AaNvqcmgL0k


My GPU/CPU usage is abour 60-70% and Vram at 2500.
I am not sure why my fps flactuates between 50-60

Vsync is turned on and i am using a 60hz display.

My system:
GTX 980
I7 4790k @ 4,6ghz
16gb DDR3 Ram (1600)
Samsung Evo 860 SSD

The PC has been Formated a week ago:
I have the newest Driver and flashed my bios to its newest version.
However it did not help.
try this step by step (read until end):
  • Disconnect from internet
  • Uninstall gpu driver using DDU (clean and do not restart, so that 2 driver could be uninstalled without needing to reboot).
  • Uninstall all the processors on device manager (should be 8 on yours, also when it asks for restart, click on no) like this:
  • Restart the pc to bios, and update to the latest bios again. Then go to bios again after update and load default or optimized settings.

  • boot up to windows and install the latest Chipset driver, reboot, go to power plan and choose amd ryzen balanced, and connect to internet.

  • Install the latest nvidia driver.

    *on Nvidia control panel, go to manage 3d settings and set the power management to adaptive.

    *do this all offline until reboot after installing chipset driver, also you may reboot to bios after all of this to set the XMP (and previous settings you did) and make sure ram is on slot 2 and 4. Download needed files (highlighted word) before doing step 1, do the step by orders.

  • And check windows update (and optional updates) if there is any and install them. Also enable Hardware Accelerated Graphics Scheduling (available on the latest win 10 update) in graphics settings like this and reboot:
Make sure the psu connected to the gpu is 1 pcie cable per 1 slot (use main cable, not the branches/split) like this:
 

ASK THE COMMUNITY

TRENDING THREADS