GFWL not working on windows 8

cnawodya

Distinguished
Jun 4, 2011
52
0
18,630
0
Hi guys,I recently tried to play some GFWL games on windows 8,but after I opened the game GFWL menu doesn't show up,even though I pressed home button.So how can I solve this problem.Help please
 

jpishgar

Splendid
Overlord Emeritus
Here's how to fix your issue:

1. Delete all previous installations of Games for Windows Live AND Microsoft Games for Windows Marketplace.
2. Download the installer here. - http://www.xbox.com/en-US/LIVE/PC/DownloadClient
3. Install the client and run it. It may ask you to download an update. Do so and install it.
4. Launch GFWLive.exe from C:\Program Files (x86)\Microsoft Games for Windows - LIVE\Client.
5. GFWL should work now for you.

If it doesn't work, or you have any issues, repeat step 1 and then before installing, right-click, go to properties, change compatibility to "Windows 7", save and exit. Then right-click the installer and choose "Run as administrator".

Hope this helps!
 

dwhee

Distinguished
Dec 9, 2011
16
0
18,510
0
This helped me, thanks!

Microsoft really needs to get Windows 8 in order. This just shows that you shouldn't bother upgrading for a desktop.
 

Exera

Honorable
Jul 18, 2013
1
0
10,510
0


Actually Windows 8 works perfectly on a desktop, what they SHOULD get in order is GFWL(which is the issue here and not W8) which is utter rubbish and thats a shame because there are some really great games that requires it.

Thatnks for the solutions though :)

 

Brandon Bassler

Honorable
Aug 7, 2013
1
0
10,510
0


yeah so.... *sniff* I've tried to several times even CCleaner'd it with registry and everything :-/

Windows 8 supa graphics card everything -.- dunno wtf is going on... but ran as admin, compatibility selected EVERYTHING .... it worked before windows 8 did their lovely "system repair" aka delete all of your programs but dont actually fix the OS lol ...
 

The Song

Honorable
Sep 7, 2013
18
0
10,510
0
 

S M Ali Ayon

Honorable
Sep 28, 2013
2
0
10,510
0
 

cinos

Honorable
Oct 19, 2013
1
0
10,510
0


ALTERNATIVE OPTION

If you cant seem to get games for windows live to work no matter what you do and you want to play with people you know all of you then download tungle and make your account and all that good stuff then look for the dark souls prepare to die network located on the left and connect to it. Its the summon signs appear almost instantly. I am not the first one to post this and i don't own any of the programs named.
 

pintu ray

Honorable
Dec 22, 2013
2
0
10,510
0


 

TerminalKiller

Reputable
May 3, 2014
2
0
4,510
0


 

TerminalKiller

Reputable
May 3, 2014
2
0
4,510
0
it din't worked i tried many times, but it showed this "Windows can't find ''C:/program files (x86)/Microsoft games for windows live/ClientGFWLive.exe"make sure you typed word correctly!" what to do?plz help me guys !!!!!!!!???????/
 

Hassaan War Hero

Honorable
May 10, 2013
146
0
10,710
17

i found a way to play games like lost planet 2 on win 8.1 pro (without gfwlive)

read Lyxer Loader's comment of April 11, 2014 at 11:47 AM

http://mediafire-gamer.blogspot.com/2013/12/lost-planet-trilogy-engrusmulti9-repacks.html

download, extract and copy these 2 files in the game
 

MrMcMufinMan

Reputable
Jan 18, 2015
1
0
4,510
0


i tried all of this and when i downloaded the update, it downloaded just fine but when i tried installing it, it kept failing. im running windows 8 and i have Games for Windows running in compatibility mode for w7 AND have it defaulted to run as an admin. why is this happening? so far i wasted my money buying a game that i can't even f*cking play apparently
 

ASK THE COMMUNITY

TRENDING THREADS