Question Gigabit mirage

Feb 21, 2020
7
0
10
0
I've been struggling trying to establish a Gigabit connection to my Askey RTV1907VW (provided by ISP) on my ASUS X52JT which, despite being 9 years old, still manages to let me operate my everyday chores effortlessly. My ISP plan provides 1Gbps through FTTC, and it successfully displays on the router page as a steady 928Mbps alignment.
Now, the problem is my laptop gets a dreadful capped connection at 100Mbps. On both Win7 and 10 (dual boot). With stock and non-stock NA drivers. 1Gbps Full-Duplex enabled (btw enabling this caused quite a few problems with some driver versions by showing a "Cable unplugged" NA status) or on Auto Negotiation. And a new Cat7 cable. Straight to the router.

In these situations the problems can usually reside in:
1) a faulty cable;
2) router not delivering the proper capable max speed to the device; or
3) NA being a pain in the ass

1) Can't definitely blame the new cable which delivered the correct Gigabit connection in a trial to a 2006 Dell laptop on WinXP (!!!)
2) Can't manually set the speed value, and from a friend's experience with the same one it can deliver a Gigabit connection from all 4 of the ethernet ports. Furthermore, it also detects the connection from the laptop as a "100Mbps" one
3) Taking for granted that the NA supports Gigabit connections (JMicron PCIE Gigabit adapter, ID PCI\VEN_197B&DEV_0250&SUBSYS_19051043&REV_03), I've tried any driver I could (still) find for it, whether it be from ASUS Support website or elsewhere, from the oldest version which might have been the stock one to the most recent one. Now I'm holding onto the only one that doesn't show "Cable unplugged" with "1Gbps Full-Duplex" enabled, but still only delivers 100Mbps. I've never really used (or abused) the ethernet port on the laptop, always stuck to Wi-Fi.

Any suggestion from you guys? Other than throwing the laptop out the window or switching to the 2006 Dell? 😭:sweatsmile:
 
Pretty much you have no other option but to leave it in auto negotiate. You would have to be able to set both ends to hard code it and no consumer router has that option. Setting only 1 end gives almost random results many times it will actually drop to 100mbps half duplex on the side that is using auto negotiation.

This is almost purely a hardware thing. Drivers are not involved much at all and even if they were the speed negotiation part has been standard for so many years it is unlikely there is a bug.

If you are seeing the speed at 100mbps in the status on the machine then there are not many things it can be. These are almost always cable issues. Problem is even new cables can be bad and some machines will tolerate a cable that is out of spec more than others. The meters to actually see if a cable meet certifications is out of the price range for most home users. The large problem with cables is all the fake cables being sold. Check that your cables are pure copper (no CCA) and have wire size 22-24 (none of that thin or flat cable)

After this you are pretty much left with the ports. Since you have tried mulitple ports on the router it means it would more likely be the pc port. You can not fix or replace these so this is one of those things you have to hope it is not. The only options is a add in card if you have a actual bad port.

Now this is a far different problem than if the port is really at gigabit but it does not transfer data at that speed. A ethernet port running at 100mbps get about 94mbps. If you are actually getting 100mbps then something else is involved because there is overhead that is not counted in the communication so you can't actually get 100mbps on a 100mbps connection.
 
Reactions: wiwarez
Feb 19, 2020
55
7
35
1
I was having a similar issue awhile back; then it hit me, it must be something so simple. It was: I was using a lan cable mis-labeled cat 7, but it was obviously a chinese knock-off and was just a cat 5, which has the 100 mpbs throttle built into it. changed to a real cat7 cable and now i get 998Mbps down. Maybe you get lucky here. But, you did say it is 9 years old, it is possible it has experienced partial failure, or lost driver support completely, again unlikely though.
I see you're likely using an old version of windows still, so:

Also Consider Disabling NETWORK THROTTLING ....................................

Network throttling is used in some versions of Windows (including Vista and Windows 7).

Here is how to Disable Network Throttling in the Registry (backup or do a file > export before editing the registry):

  1. Go into the Registry (if you don't know how to do this then you're not qualified to do this)
  2. Navigate your way to
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Multimedia\SystemProfile
  1. Locate the entry named NetworkThrottlingIndex
  2. To turn the feature off completely, change the value to FFFFFFFF (hexadecimal)
Remember, that editing the registry can be risky if you don’t know what you’re doing.

Is it possible to replace the NIC? it is listed as a PCIe device... But it is hard to find any other info on your specific device. Except that 10/100/1000mbps is surely supported.

FDon't "rule out" your "new" cable, unless you rolled it yourself ;) It IS possible that it will work in one and not the other because it isn't actually spec, and note they likely aren't the same NIC; however unlikely, I have seen it more than a few times.

Have you EVER gotten a 1000mbps connection using this card, and can you try to find a specific model number for that exact card? not much to find using the driver unfortunately.
Maybe a linux or winxp driver can get it to work, i'd also double check the router settings, this may be something as simple as the card being so old or obscure it relies on legacy technologies not typically enabled by default in modern routers.

Here's hoping something in there helps, and if not, I'll be awaiting a model number so that I can dig some more, I won't be able to get my hands on the router since it is an ISP specific model. I'd advise getting rid of it though, ISP exclusive hardware tends to be lower quality, less compatible, and have more unpatched vulnerablities like yours: https://nvd.nist.gov/vuln/detail/CVE-2019-12489
 
Last edited:
Reactions: wiwarez
Feb 21, 2020
7
0
10
0
Check that your cables are pure copper (no CCA) and have wire size 22-24 (none of that thin or flat cable)
Hmm, this one is the AmazonBasics' Cat7 model. Someone said: "S/FTP is implied by description: "Each individual twisted pair comes shielded with Aluminum Mylar foil and then is bundled together with an 85% tinned copper braid shield." "

If you are actually getting 100mbps then something else is involved because there is overhead that is not counted in the communication so you can't actually get 100mbps on a 100mbps connection.
Sorry didn't properly specify, it identifies a 100Mbps connection but I'm getting a bit less, as I should.
Network Status Speedtest
 
Feb 21, 2020
7
0
10
0
So in situations like this, I boot a linux live cd and see what type of speeds it gets to see if it's the hardware or just windows messing up. Try that and report back.
That'll be the next thing I'm going to try. I'll let you know

EDIT: Tried the cable out on another laptop, (Acer A55DR-SX), delivers Gigabit connection :mad:
 
Last edited:
This is the problem with cables. First you should not have purchased cat7 in the first place. The standard was never fully finalized by all the certification places so it just invites fake cable since "CAT7" really means nothing.
The standard for 10gbit connections is cat6a.

Next you really need nothing better than cat5e for gigabit. More expensive cable buys you nothing.

Quality cable will have the wire size and type of wire printed on the cable. Most cable that is actually a licensed and certified cable will say EIA/TIA on the side. Unfortunately some china companies have put that marking on fake cables. Many fake cables say nothing on the wire I suspect to avoid getting sued.

The main problem with fake cables is they work on some machines and not others. They will work ok at short distance but if you try longer cables they will fail or maybe drop to 100mbps.

Then again it could be that your cable is just defective. 1 pin just slightly loose or corroded could be the cause.

You cheapest option is likely to just buy another cable and hope you do not have a defective port.
 
Reactions: wiwarez
Feb 21, 2020
7
0
10
0
This is the problem with cables. First you should not have purchased cat7 in the first place. The standard was never fully finalized by all the certification places so it just invites fake cable since "CAT7" really means nothing.
The standard for 10gbit connections is cat6a.

Next you really need nothing better than cat5e for gigabit. More expensive cable buys you nothing.

Quality cable will have the wire size and type of wire printed on the cable. Most cable that is actually a licensed and certified cable will say EIA/TIA on the side. Unfortunately some china companies have put that marking on fake cables. Many fake cables say nothing on the wire I suspect to avoid getting sued.

The main problem with fake cables is they work on some machines and not others. They will work ok at short distance but if you try longer cables they will fail or maybe drop to 100mbps.

Then again it could be that your cable is just defective. 1 pin just slightly loose or corroded could be the cause.

You cheapest option is likely to just buy another cable and hope you do not have a defective port.
Did I need to mention the one I bought is 7m (22ft)?
Anyway, I'll send it right back and find another one, although the italian Amazon doesn't really offer much other choice unfortunately, as far as certified materials. Heaping with chinese companies.
 
Unfortunately even amazon themselves sell fake cables. For some reason they will not sell a fake purse but fake electronics is ok.

In these cases you are better off buying from a store where you can actually look at the cable before you buy it. There are reputable cable providers online but I can't recommend one for where you live.

You might try looking for brand name cable. Belden is a major manufacture of cable. Not sure if they actually make patch cables, mostly they make bulk cable. There are many companies that buy belden cable and then put ends on them. I know the place I buy from will make custom cables and many times the wire is marked belden.
 
Reactions: wiwarez
Feb 21, 2020
7
0
10
0
Also Consider Disabling NETWORK THROTTLING ....................................

Network throttling is used in some versions of Windows (including Vista and Windows 7).
Alright, just disabled it :)

Have you EVER gotten a 1000mbps connection using this card, and can you try to find a specific model number for that exact card? not much to find using the driver unfortunately.
No, never got a gigabit connection with the laptop because we've had the Gigabit fiber upgrade for a couple years now but I wasn't living here back then.
As for the model number, which doesn't appear anywhere on the system, I'll open up the laptop. It's supposed to be marked on the actual adapter anyway, right?
 
Feb 19, 2020
55
7
35
1
Ideally there will be a number on a sticker on there somewhere that will either identify the card itself, or at least help me identify the chip itself, which may help us identify and fix the issue ourselves if it is driver related (I often bake my own drivers for old hardware with odd issues not always similar to this). If you're comfortable opening it, that would be great. I didn't want to ask that of you, so i'm glad you offered. This feels like one of those needle/haystack issues my gut says. Hopefully we can track it down.

First try to identify the card, or the chip it runs on, then I can try to get my hands on some of the hardware and reproduce the issue. Or I can audit some of the drivers, and see if we can bake one to fit.

Considering it works at full duplex at 1000Mbps on another PC, we can assume the cable is "capable" of carrying the signal. This doesn't rule out, but lessens the likelihood of crosstalk or bad internal wiring/shielding by alot. Out of curiosity, the new cat7 cable, is it a twisted pair cable (round) or a parallel cable (flat)?
If you're willing to swap out the cable, try going to a local store, and grab any old cat5E or cat6 cable, as these specs have been officially standardized. cat7 hasn't actually been standardized yet, so manufacturers can put a ca7 "stamp" on anything capable of carrying a 1000MHz signal, and doesn't actually mean it can transmit anything at all in terms of networking. And true 40Gbps cables, are not copper, they are Fibre Channel Cables.
I think this issue here, may actually be that your cable is in fact too new, because the type of wiring and physics used to move the signal; it is VERY possible that your card won't use the cable "because" it is shielded. In the I.T. industry we usually avoid cat7 and either use true cat8 or cat6E depending on the need. Here's why:
They're NOT really network cables!

*Class FA (Class F Augmented) channels and Category 7A cables, introduced by ISO 11801 Edition 2 Amendment 2 (2010), are defined at frequencies up to 1000 MHz, suitable for multiple applications including CATV (862 MHz).[citation needed]

The intent of the Class FA was to possibly support the future 40Gigabit Ethernet: 40Gbase-T. Simulation results have shown that 40 Gigabit Ethernet may be possible at 50 meters and 100 Gigabit Ethernet at 15 meters.[citation needed] In 2007, researchers at Pennsylvania State University predicted that either 32 nm or 22 nm circuits would allow for 100 Gigabit Ethernet at 100 meters.[3][4]

However, in 2016, the IEEE 802.3bq working group ratified the amendment 3 which defines 25Gbase-T and 40gbase-T on Category 8 cabling specified to 2000 MHz. The Class FA therefore does not support 40G Ethernet.

**As of 2017 there is no equipment that has connectors supporting the Class FA (Category 7A) channel.

***Category 7A is not recognized in TIA/EIA.

They weren't intended for networking use in the traditional sense, they more for making a private MOCA style connection between storage devices in commercial settings (hence it was NEVER accepted, and never will be). Also a cat7 signal is only good for about 90ft or so.

The issue here, could be that you're not getting crosstalk with the cat7 cable, when you should be, and the NIC you're using relies on tech that uses the crosstalk to push the signal.

Here's to hoping that an OLDER cat5E/6A cable will be the magic key!

*ISO/IEC 11801-2Part 2: Office premisesISO/IEC 11801Cabling for commercial (enterprise) buildings
This is an oversight that many make when selecting a cat7 cable, as it is not for general networking, more of a custom cable for custom networking applications. For example we used a bunch of fibre cat 7 cable to run an internal intersite network for a large media company. Companies like to transfer files and data from one location to another, on a "private" line, this requires the use of custom protocols and so on, things you couldn't access with a normal browser. The internet standard works because it is standardized, there are limitless ways to build a network stack, and this cable isn't made for the one you're using. so it may work in one system the way you expect, but not another.

** Is your NIC older than 2007, bychance? I know it is ;) The other pc worked because you got lucky (methinks).

*** There is a reason for this, and I believe the problem you're experiencing, may be part of that reason. ;)

Let me know if this does indeed work, and if not, I'll be waiting for that model number or some identifying info. Feel free to take a pic of the chip itself ;D
 
Last edited:
Reactions: wiwarez
Feb 21, 2020
7
0
10
0
Reporting back: checked some info of the NA from a Linux distro (Kubuntu 19.10), although ethernet connection wasn't working on that and I found out that's a known bug for my specific NA on Linux from version 16 onwards (?) due to, and I quote a JMicron referee,
The JMC25x/JMC26x Gigabit Ethernet Chip was mass production at 2008Y, at that time, the IEEE802.3az specification wasn’t ready. So this chip will have a connection issue while connecting to all the IEEE 802.3az enabled devices, that is, if the ‘Speed & Duplex’ feature sets to ”Auto Negotiation” mode or ”1Gbps/Full Duplex” mode, then the link function is abnormal, i.e. link down. Therefore our S/W engineer made a workaround - ASD(Auto-Speed-Down) function to force the LAN speed keeping in 100Mbps when the ‘Speed & Duplex’ feature has been set to “Auto Negotiation” mode or ”1Gbps/Full Duplex” mode. My suggestion is to use non-IEEE802.3az Gigabit equipment then your connection speed would keep as 1Gbps.
Anyway, got the following from command:
Code:
kubuntu@kubuntu:~$ sudo lshw -class network
  *-network                
       description: Wireless interface
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wls1
       version: 01
       serial: 48:5d:60:c6:78:aa
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=5.3.0-18-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:17 memory:d2a00000-d2a0ffff
  *-network
       description: Ethernet interface
       product: JMC250 PCI Express Gigabit Ethernet Controller
       vendor: JMicron Technology Corp.
       physical id: 0.5
       bus info: pci@0000:05:00.5
       logical name: ens5f5
       version: 03
       serial: bc:ae:c5:9f:4b:59
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm pciexpress msix msi bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=jme driverversion=1.0.8 duplex=half latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:39 memory:d0200000-d0203fff ioport:9100(size=128) ioport:9000(size=256)
kubuntu@kubuntu:~$ sudo ethtool ens5f5
Settings for ens5f5:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: Yes
        Supported FEC modes: Not reported
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Half 1000baseT/Full
        Advertised pause frame use: Symmetric Receive-only
        Advertised auto-negotiation: Yes
        Advertised FEC modes: Not reported
        Speed: 10Mb/s
        Duplex: Half
        Port: MII
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pg
        Wake-on: g
        Current message level: 0x000020c6 (8390)
                               probe link rx_err tx_err hw
        Link detected: no
kubuntu@kubuntu:~$ dmesg | grep -e jme -e ens5f5
[    1.380837] jme: JMicron JMC2XX ethernet driver version 1.0.8
[    1.380861] jme 0000:05:00.5: can't disable ASPM; OS doesn't have ASPM control
[    1.381898] jme 0000:05:00.5 eth0: JMC250 Gigabit Ethernet chiprev:23 pcirev:3 macaddr:bc:ae:c5:9f:4b:59
[    1.417324] jme 0000:05:00.5 ens5f5: renamed from eth0
[   25.880674] jme 0000:05:00.5 ens5f5: Link is down
kubuntu@kubuntu:~$
If it's not enough I'll go ahead and open the baby up tomorrow
 
That standard is related to power save mode. Mostly I have seen this on switches and it causes all kinds of problems. Your router likely does not support it but if it does you can turn this option off in most devices.

If I read this correctly it only connected 10m half duplex. It most times means a bad cable but it can also be a symptom of a hard coded speed/duplex on the pc side. Not sure it looks like auto on this end. The router likely does not have the ability to set speed/duplex.
 
Feb 21, 2020
7
0
10
0
Ideally there will be a number on a sticker on there somewhere that will either identify the card itself, or at least help me identify the chip itself, which may help us identify and fix the issue ourselves if it is driver related (I often bake my own drivers for old hardware with odd issues not always similar to this). If you're comfortable opening it, that would be great. I didn't want to ask that of you, so i'm glad you offered. This feels like one of those needle/haystack issues my gut says. Hopefully we can track it down.

First try to identify the card, or the chip it runs on, then I can try to get my hands on some of the hardware and reproduce the issue. Or I can audit some of the drivers, and see if we can bake one to fit.

Considering it works at full duplex at 1000Mbps on another PC, we can assume the cable is "capable" of carrying the signal. This doesn't rule out, but lessens the likelihood of crosstalk or bad internal wiring/shielding by alot. Out of curiosity, the new cat7 cable, is it a twisted pair cable (round) or a parallel cable (flat)?
If you're willing to swap out the cable, try going to a local store, and grab any old cat5E or cat6 cable, as these specs have been officially standardized. cat7 hasn't actually been standardized yet, so manufacturers can put a ca7 "stamp" on anything capable of carrying a 1000MHz signal, and doesn't actually mean it can transmit anything at all in terms of networking. And true 40Gbps cables, are not copper, they are Fibre Channel Cables.
I think this issue here, may actually be that your cable is in fact too new, because the type of wiring and physics used to move the signal; it is VERY possible that your card won't use the cable "because" it is shielded. In the I.T. industry we usually avoid cat7 and either use true cat8 or cat6E depending on the need. Here's why:
They're NOT really network cables!

*Class FA (Class F Augmented) channels and Category 7A cables, introduced by ISO 11801 Edition 2 Amendment 2 (2010), are defined at frequencies up to 1000 MHz, suitable for multiple applications including CATV (862 MHz).[citation needed]

The intent of the Class FA was to possibly support the future 40Gigabit Ethernet: 40Gbase-T. Simulation results have shown that 40 Gigabit Ethernet may be possible at 50 meters and 100 Gigabit Ethernet at 15 meters.[citation needed] In 2007, researchers at Pennsylvania State University predicted that either 32 nm or 22 nm circuits would allow for 100 Gigabit Ethernet at 100 meters.[3][4]

However, in 2016, the IEEE 802.3bq working group ratified the amendment 3 which defines 25Gbase-T and 40gbase-T on Category 8 cabling specified to 2000 MHz. The Class FA therefore does not support 40G Ethernet.

**As of 2017 there is no equipment that has connectors supporting the Class FA (Category 7A) channel.

***Category 7A is not recognized in TIA/EIA.

They weren't intended for networking use in the traditional sense, they more for making a private MOCA style connection between storage devices in commercial settings (hence it was NEVER accepted, and never will be). Also a cat7 signal is only good for about 90ft or so.

The issue here, could be that you're not getting crosstalk with the cat7 cable, when you should be, and the NIC you're using relies on tech that uses the crosstalk to push the signal.

Here's to hoping that an OLDER cat5E/6A cable will be the magic key!

*ISO/IEC 11801-2Part 2: Office premisesISO/IEC 11801Cabling for commercial (enterprise) buildings
This is an oversight that many make when selecting a cat7 cable, as it is not for general networking, more of a custom cable for custom networking applications. For example we used a bunch of fibre cat 7 cable to run an internal intersite network for a large media company. Companies like to transfer files and data from one location to another, on a "private" line, this requires the use of custom protocols and so on, things you couldn't access with a normal browser. The internet standard works because it is standardized, there are limitless ways to build a network stack, and this cable isn't made for the one you're using. so it may work in one system the way you expect, but not another.

** Is your NIC older than 2007, bychance? I know it is ;) The other pc worked because you got lucky (methinks).

*** There is a reason for this, and I believe the problem you're experiencing, may be part of that reason. ;)

Let me know if this does indeed work, and if not, I'll be waiting for that model number or some identifying info. Feel free to take a pic of the chip itself ;D
 

ASK THE COMMUNITY

TRENDING THREADS