Question Gigabyte 660

Jan 16, 2020
19
0
10
0
Hi All,

I have a new Gigabyte 660 graphics card.
It has two power cable. Will I have to supply power to both cables or single cable.

I am confused.

Please help.

Thank you in advance if you can help.
 
Jan 16, 2020
19
0
10
0
Have you tried running DDU just to be sure?
A more extreme, but direct attempt would be a fresh install of windows.
If that didnt work, then its likely a hardware problem. A "new" 660 sounds hard to come by.

What's DDU?

I just bought this graphics card 1month a ago.
 
Jan 16, 2020
19
0
10
0
May be you can have a look of my graphic card it has this two power cables (3pins each).
Should I plug in both to the power source?
Image298.jpg
I was using only one to power it and it was working fine.
I had no issues.
 
What PSU are you using? GTX 660 requires 450w PSU.

Connect graphics card with 6pin connector directly from PSU. If your PSU doesn't have 6pin connector, then most likely it will not be able to support the graphics card (even with 2x molex to 6pin adapter, you're using).

Install driver version listed in gigabyte support site ( version 384.76). With latest driver version from Nvidia site you may get issues.
https://www.gigabyte.com/Graphics-Card/GV-N660OC-2GD/support#support-dl-driver

If this doesn't solve your issues, then assume your GTX 600 is faulty.
 
Reactions: TheKing469
Jan 16, 2020
19
0
10
0
What PSU are you using? GTX 660 requires 450w PSU.

Connect graphics card with 6pin connector directly from PSU. If your PSU doesn't have 6pin connector, then most likely it will not be able to support the graphics card (even with 2x molex to 6pin adapter, you're using).

Install driver version listed in gigabyte support site ( version 384.76). With latest driver version from Nvidia site you may get issues.
https://www.gigabyte.com/Graphics-Card/GV-N660OC-2GD/support#support-dl-driver

If this doesn't solve your issues, then assume your GTX 600 is faulty.
I don't have a six pin connector in my PSU.
I have a 450W PSU.

So, should I connect both 2x molex to the power supply?

It was working fine for last 1month, with 1molex connector.

The problem is I never had a graphics card earlier so I didn't knew how to install. Watched some videos on YouTube and it worked fine till yesterday.
 
Jan 16, 2020
19
0
10
0
Any way my problem is somehow solved.

I just connected the 2molex connector to my PSU and it is working fine.

I really dont know what was the actual issue.

It was a big surprise for me, How my GPU was functioning for last 1month with single 3pin molex connector while it is build to run with 6pins.

It has been more than 1hour now my PC is running smooth as butter.

Hope I wont face any other issues.

Thanks to Gam3r01 and SkyNetRising for the support.
 

ASK THE COMMUNITY