Question Gigabyte A520I AC won't post with Ryzen 5600G

Oct 30, 2022
2
0
10
0
I just put together a PC, but it isn't able to post or display anything. I started all over to the bare minimum but it still doesn't work.
  1. I removed all the hardware from the motherboard including CPU, RAM, and hard drive. Nothing was plugged in except for motherboard power
  2. I turned off the power supply, used a screwdriver to clear CMOS by shorting the two pins, and then removed the CMOS plug as well. Waited 5 minutes to clear CMOS. Plugged the CMOS plug back in
  3. I downloaded the latest BIOS to enable support of the Ryzen 5600G CPU and loaded it onto an 8GB flash drive formatted to FAT32. I renamed to file to gigabyte.bin, plugged it into the motherboard, turned on the power supply, and then pressed the QFlash button. The lights blinked for about 3-5 minutes and then stopped, so I assumed it worked.
  4. I inserted my Ryzgen 5600G CPU into the board, plugged in the CPU fan, plugged in the MOBO and CPU power, plugged in the front panel lights, plugged in HDMI, and turned everything on. The front panel lights are able to turn on, the CPU fan spins continuously, but I'm not able to post. No display at all
Some other things I tried:
  • Tried using both HDMI ports and the Display port too. Monitors and cables definitely working, I'm using them actively for another machine
  • Checked the CPU and the CPU slot and don't see any breaks or bent pins or any other physical issues
  • Plugged in a motherboard speaker but it isn't making any sounds
  • Tried plugging in a single RAM card, doesn't POST
  • For Qflashing
    • Tried qflashing to the older F14 version
    • Tried using a different flash drive (32GB FAT32)
    • Made sure that the ATX 12v and Mobo power was plugged in; waited until the light and PSU fan stopped spinning
Suspecting maybe my motherboard is no good? Not sure what else to do
 

ASK THE COMMUNITY