[SOLVED] Gigabyte AB350 Gaming 3 not setting to 3200mhz

Nov 26, 2018
4
0
10
0
Hi,
I have G. Skill 2666mhz ram(2x4) that was running in xmp mode,
I recently bought Trident Z 3200mhz ram(2x8) both in dual channel..

After adding the tridentZ, xmp is auto setting the tridentZ to 2666mhz and not 3200mhz.

There doesnt seem to be an option to change each rams frequency.

Is this expected?
 

jojesa

Illustrious
RAM above 2133 is considered overclocked and is expected to worked at rated speed on tested motherboards.
Gigabyte provides a Qualified Vendor List (QVL) of tested RAM for the AB350 Gaming 3 motherboard.
Ram not listed to run at 3200MHz might not run at that speed but it will default to a lower speed, like in your case.
Try setting the RAM to 2933 or 3000MHz and see if works. You won't see a difference in performance between 2933 and 3200MHz in real word usage.
You might try configuring RAM settings manually (speed, timing, voltage, etc).
See if there is a motherboard update, which sometimes could have firmware for new RAM modules and speed.
Ryzen 1st Generation 300 series motherboard are a little finicky when it comes to RAM speed.
Which CPU do you have?
What's the model of the Trident Z 3200MHz RAM
 

jojesa

Illustrious
RAM above 2133 is considered overclocked and is expected to worked at rated speed on tested motherboards.
Gigabyte provides a Qualified Vendor List (QVL) of tested RAM for the AB350 Gaming 3 motherboard.
Ram not listed to run at 3200MHz might not run at that speed but it will default to a lower speed, like in your case.
Try setting the RAM to 2933 or 3000MHz and see if works. You won't see a difference in performance between 2933 and 3200MHz in real word usage.
You might try configuring RAM settings manually (speed, timing, voltage, etc).
See if there is a motherboard update, which sometimes could have firmware for new RAM modules and speed.
Ryzen 1st Generation 300 series motherboard are a little finicky when it comes to RAM speed.
Which CPU do you have?
What's the model of the Trident Z 3200MHz RAM
 
Nov 26, 2018
4
0
10
0
Ive troubleshooter some more.. Manually setting the memory timings to the correct values
(CL16-18-18-18-38 anf 1.35V) caused my pc to reboot once, and the settings didnt change but now windows only reads 2133mhz on all the ram..

Note: cpu is ryzen 5 2400g

It seems updating the bios might be the only option.. Weird how there isnt an option to set per ram frequency manually instead of all of it at once..
 

jojesa

Illustrious
With the 2nd generation ryzen 5 2400g, you should have gone with a 2nd generation 400 series motherboard (B450).
They worked some of the RAM quirks found on the 300 series.
Update the BISO and see if you could get better performance.
 
Nov 26, 2018
4
0
10
0
Okay, ive updated the bios to the latest version (F25) and nope, still auto sets to 2666mhz and if i make it higher then it just resets bios to default settings.

If i take out the 2666mhz ram then it sets to 3200mhz for the tridentz.

Extra info: in task manager on windows it also says each slot in ram is at 2666mhz (slot 1-4)

If i set CAS timings and voltage to the tridentZ's then bios boots correctly without resetting but windows reads all ram at 2133mhz then...

So i guess ill later sell the 2666mhz.
 

ASK THE COMMUNITY