Question Gigabyte Aorus elite motherboard is blinking red, not booting to bios, any solutions?

Nov 4, 2020
29
2
45
1
Let's get to the issue directly, my Gigabyte Aorus elite motherboard is not booting to bios and just blinking red twice per second and continues indefinitely ( I let it do so for around 5mins for not risking any damage to maybe other components). *PC specs given at the end.

#Things to note here(observations)
- cpu fan is not showing any response not even rgb ring showing any light.
- when tried to boot up system for very first time with all cables plugged in, cpu fan was being started and then smoke came out and motherboard immediately got shut down and I turned off the power ASAP.
- about cpu cooler, it is working fine with another motherboard.
- other cpu cooler is not working with Gigabyte Aorus motherboard
- red blinking strip running along the left side and joining to the southbridge and southbridge blinking red as well.
- none of the other components booting up like case fans, rgb strip,etc. However all this rgb stuff worked before smoke came out.
- whilst red light was blinking PSU fan was deflecting somewhat in sync with blinking.
- plugging cpu fan into case fan header did not work.
- when power button from the case is being pressed and held until red light blinks, the power button blinks too in sync with red blinking light on the motherboard.
- I'm sure every cable (24 pin, 8 pin, 6+2 pin) is plugged tightly.

#My conclusion:
- as cpu fan is working flawlessly I think CPU fan header on the motherboard is burnt.
- I think motherboard is looking for cpu fan on the respective header and as header is not working, motherboard is not letting any power go into the rest of the parts like case fans, rgb strip.
- whether I connect cpu fan or any other case fan it is not working and that thing may be motherboard sensing as absence of cpu fan and shutting down the whole system as precaution for not getting processor overheated (the light that is blinking red is under southbridge and not one of those leds those indicate lack of the components which are situated beside the southbridge).
- My FINAL CONCLUSION - cpu fan header is defective.

And please tell if there is any way to fix cpu fan header.
Looking for the solution desperately :(

#PC specs :
Motherboard- Gigabyte b450 aorus elite - ATX
Processor- AMD ryzen 7 2700
Cooler- Stock cooler, came with processor
Gpu- Gigabyte GeForce gtx 1660 super, 6gb, OC edition
PSU- Corsair CV550, 550w
Memory- HyperX fury 8gb 3200mhz, 2 sticks
HDD - seagate compute 1TB internal hard drive
 
use minimum config, remove all LED stripes, test the motherboard on a non conducting surface (no packaging of the motherboard or similar!):

only plug in:
one RAM in Dimm slot DDR4_1 or DDR4_2 (you can check one RAM in all slots for testing), motherboard, cpu with cooler+ fan, PSU, GPU, keyboard


reset the BIOS by jumper clrCMOS

However all this rgb stuff worked before smoke came out.
check where exactly the smoke came out, you can usually smell where

eventually the PSU is faulty

LED stripes might be plugged in incorrectly
 
Nov 4, 2020
29
2
45
1
Thanks for your immediate response :)

I've tried interchanging both ram sticks in different ram slots.
Tried to eliminate possibly the faulty component but even with minimum specs it shows blinking red light.
Even for me to know if test is working or not, the motherboard has to give some responses like cpu fan spinning or led ring on the cpu fan is lit up.
Smoke came out definitely from the area near cpu cooler.
And I still suspect the cpu fan header is culprit
 

ASK THE COMMUNITY

TRENDING THREADS