Question Gigabyte Aorus Elite X570 M.2 Drive not showing up. Please Help.

Oct 4, 2020
1
0
10
0
Hello everyone! I'm new to the forum. I searched a little before i post but i don't seem to find an answer.

So i upgraded my system a couple months ago (specs at the end of the post) and i haven't done a new Windows install right away because i wanted to install 2x nvme's that i have ordered online. So i used for a couple of days an installation of Windows 10 that i already had from my previous build on a SSD drive. When the 2 Nvme's finally arrived, i installed them on my motherboard, i booted up my old windows from the SSD, and the NVMEs worked just fine. I could see them detected in both BIOS and Windows Device Manager. So i restarted the PC and i installed a new copy of Windows 10 on one of them (On port M2B of the mobo (importand)). Booted up. Everything normal. I even installed a full game on the second NVME, which worked also just fine, without any problems. Shutted down the PC, went to sleep.

The next day... I unpluged my old SSD and i pressed the power botton. PC boots up, Windows working. But the second NVME is not there. Nowhere to be found. I restarted the PC and i can't even find it in the BIOS menu. The other NVME (Corsair MP600 on M2B port) works perfect and i can boot up until Windows with no problem at all. I use my PC since that day everyday. That other NVME (on M2A port) just wants to drive me crazy and here is why.

In the last few weeks i think i searched the whole internet trying to find an answer. Every single option i found doesn't seem to help. The only thing i've done and i actually saw some progress was when i switched the drives on the ports. Both drives work perfectly on M2B port (second port of the mobo) and don't show up at all when i install them on the M2A port. So i got to the conclusion that something is wrong with that port (M2A port right over the GPU). It shows up as a port in the BIOS menu but when a drive is been plugged in it just says N/A and i can't see or use the M2 drive.

After i checked all the options the BIOS has to offer, i ended up using only one M2 drive (Corsair) on the M2B port for my Windows and 2 SATA drives for games and other stuff. I left the other NVME port empty and that second M2 drive remains in its box until i find a way to make that port usuable.

Specs:
Mobo: Gigabyte AORUS Elite X570 Rev 1.0 (Latest BIOS Update F30)
CPU: AMD Ryzen 7 3700x
RAM: G.Skill Trident Z neo 32GB (2x16GB) 3.600mhz
GPU: AMD Radeon RX 5700XT from ASUS
M2A NVME Port: Kingstone A2000 (Doesn't work at the moment)
M2B NVME Port: Corsair MP600 500GB (Windows 10)
HDD: Seagate Barracuda 2TB
SSD: WD 500GB (Here was the Windows installation. Now it's just storage)
PSU: Turbo-X 600w 80+ Bronze

Please. Help me. And thank you in advance.

PS.: I've tried a wonderfully writted tutorial of how to install a NVME here on the forum but it doesn't help with my problem.

PS.2: Sorry for my English and the long post :)
 

ASK THE COMMUNITY

Latest posts