Gigabyte Auros Z370 Gaming 7- General questions after first build.

Jan 15, 2019
4
0
10
1
Hey, folks. Just built my first PC and have been lurking this site for a couple of months to get some questions answered during that process. I've read the motherboard manual throughout the build, but I have a few things that I wanted to inquire about that I could not find using the search function.

Side note: I have everything up and running, NVIDIA driver installed, a couple of Intel drivers installed and even downloaded a game last night and spent about 20 minutes on it this morning. Just wanting to paint that picture that I dont have anything that I would consider a major issue.

A couple of specs:
MOBO- Gigabyte Auros Z370 Gaming 7
CPU- i5 8600K
GPU- NVIDIA 1070Ti GTX
RAM- TridentZ 3200 (2 x 8GB)
Windows 10 up to date

Questions-
BIOS- Current BIOS version is F4 and the most recent I see is F11. When the file is unzipped I try and run exe. and windows pops up with the window that typically allows "run" and "dont run" options, but only has the "don't run" option. Im confident I'm selecting the right version as rev1.0 and OP are the only options. I selected rev1.0.


Drivers- I installed Intel CPU driver, LAN and 2 others of which the name excapes me at the moment. If I find the solution and am able to update to F11 (or any future update), will the BIOS automatically update and replace any necessary drivers currently installed rather than have to do all of them seperately?


Memory- RAM speed is showing 2133 with and without XMP enabled. First thought is that BIOS update will fix this and is probably the best place to start, but refer to question 1.

I appreciate all the help I've gotten since before this post and any going forward. Thanks, guys and gals.


 

ASK THE COMMUNITY

TRENDING THREADS