Question Gigabyte B450 Wifi Pro motherboard not clocking the proper ram speed

Omar_14

Reputable
Jan 13, 2016
11
0
4,510
0
Hi All,

Recently I bought a new PC which has
AMD Ryzen 5 2600
Gigabyte Aorus B450 Wifi Pro Motherboard
Corsair Vengeance LPX 8GB 3200MHz DDR4 Ram (8x2)

However, PC is running smoothly so far, but the Ram is not clocking its full speed which is 3200MHz instead it's running on 2133MHz, I have tried to change the speed by enabling the XMP from bios which works after it reboot to the windows, but it went back to 2133MHz after the next boot, and had to go back to bios to check the XMP and reboot it again.
Both the ram sticks are installed on DIMM Slot 2 and DIMM Slot 4.

The Motherboard Bios version is F30 which was updated back in july (not entirely sure).

Need experts opinion on how to put the Ram's on its full speed. I couldn't find any solution for it anywhere and come to seek you good people help from here.
 

Omar_14

Reputable
Jan 13, 2016
11
0
4,510
0
Are you saving the BIOS after you enable XMP?

I think that....if you aren't saving it....what you are describing will happen.
I am, by clicking F10 "Save and Exit" still it's not working or getting back to old form, though, there is an option called "Memory Frequency" under the XMP which is still in Auto mode, which I couldn't change it to manual.
 
I am, by clicking F10 "Save and Exit" still it's not working or getting back to old form, though, there is an option called "Memory Frequency" under the XMP which is still in Auto mode, which I couldn't change it to manual.
It sounds like you are doing it properly.

Although I am seeing when you are using two modules to have them in 1 and 2 or 3 and 4.....NOT 2 and 4.
 
Last edited:

Omar_14

Reputable
Jan 13, 2016
11
0
4,510
0

Omar_14

Reputable
Jan 13, 2016
11
0
4,510
0
You're welcome.
Okay so the update is I finally fixed the frequency issue, I had to re-slot the ram's then I install the App center tool along with the Aorus version of Easytune tool, then from there I set up the ram at 3200MHz and enabled XMP. And voila! its on the 32 mark since then, rebooted the system, runs some benchmarks and its working just fine!

Thanks for your help!
 
Okay so the update is I finally fixed the frequency issue, I had to re-slot the ram's then I install the App center tool along with the Aorus version of Easytune tool, then from there I set up the ram at 3200MHz and enabled XMP. And voila! its on the 32 mark since then, rebooted the system, runs some benchmarks and its working just fine!

Thanks for your help!
Good.
and you're welcome.
 
Reactions: Omar_14

ASK THE COMMUNITY

TRENDING THREADS