Question Gigabyte GA-870 DS3P Motherboard Corrupt.

Gardener1

Commendable
Jun 26, 2017
3
0
1,510
0
Hi only been here once so here's hoping I'm not in the wrong section.
I have a bit of a strange problem, I mistakenly unplugged my Asus router from the wall , as a consequence I seemed to have bricked the router. I have ordered another so that problems solved, but it seemed to affect my motherboard. It gave the message that it was corrupted and went into a restore mode with a bar filling up. So I re-started the computer and it did it again
Then I could not get on the internet as it affected the lan. I fixed that in the bios but the problem that I now have is each time I put a portable drive in the computer it is reading a long cannot mount message. This has happened to all 3 of my drives just by plugging them in. I can't access my external portable drives now and I can't back up my work on my computer.
I am duel boot with Linux and windows 7 tried it in windows too but no luck. Now I am completely stuck. Could you advise me on how to access my portable drives? They were all working fine till I plugged them in to my PC. I dare say the motherboard is still corrupt. Apologies I Am not too tech savvy.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS