Question Gigabyte X470 Aorus Ultra Gaming Problem

thadrolling

Distinguished
Mar 1, 2010
2
0
18,510
0
Hello -

First off, I hope I am posting this question to the right place. If not, please advise. I am a fairly technical person and I have built multiple PCs in the past, but have not built one in the past 5 years or so.

My motherboard is the Gigabyte X470 Aorus Ultra Gaming model. The problem is the motherboard won't boot to BIOS screen. The DRAM led on motherboard flashes for a long burst, then CPU led flashes for a short burst. No external vga card used, two different power supplies tried, nothing else plugged in except keyboard. I have tried the following:
  • two sticks of matched ram installed in slots 1 and 2
  • single stick of ram installed in slot 1 only
  • no ram installed
  • checked CPU for bent pins and re-seated CPU
  • plugged in external speaker: not getting any beeps at all
  • unplugged battery and cleared cmos via on board pins
The RAM is on the QVL and is Corsair Vengeance LPX 16GB (2x8GB) DDR4 DRAM 3000MHz C15 Desktop Memory Kit - Black CMK16GX4M2B3000C15. The CPU is the Ryzen 5 3600. I do not have my M2 hard drive installed (yet).

I am hoping that is enough info to get some help from this group.

Thanks in advance! ~Thad

I am out of things t
 

ASK THE COMMUNITY

TRENDING THREADS