• Now's your chance win big! Join our community and get entered to win a RTX 2060 GPU, plus more! Join here.

    Pi Cast Episode 3 streams live on Tuesday, August 4th at 2:30 pm ET (7:30 PM BST). Watch live right here!

    Catch Scharon on the Tom's Hardware Show live on Thursday, August 6th at 2:00 pm ET (7:00 PM BST). Click here!

Question Gigabyte z170 Gaming G1 Broke


May 23, 2016
Yesterday I installed a new cooler after my previous watercooling setup had sprung a tiny leak in the CPU blockhead. It worked for a day until it broke today (issue down below).
Initially, I had no USB 3.0 connectivity issue where none of my USB 3.0 ports worked. No updating of Windows software solutions helped and the only troubleshooting solution left after I reseated the USB 3.0 connector was to reset the BIOS. I believed it to be a USB 3.0 controller issue or a BIOS issue as none of the USB 3.0 ports from the motherboard itself was working as well. Right after, pressed the black CMOS SW button for 10 seconds to clear the CMOS. I also pressed the power button right after (I might've accidentally pressed both buttons at the same time by accident for a split second, I'm not really sure). Then the PW SW button stopped shining when I plugged it in. When I pressed the RST SW or CMOS PW buttons it flickered, but now it doesn't shine at all. I tried clearing CMOS the old fashioned way, switching the BIOS being used, and more, but now it simply doesn't boot. I checked for wall power and the PSU being plugged in. I tried pressing the button in both other and off state. Now it simply wont turn on and I have no clue if there's even any power going to the MOBO or if I accidentally fried the thing trying to fix my USB 3.0ports. If you have any idea what's going on, I would appreciate it.

(I also posted this on reddit to r/gigabyte so som of you maybe saw it before)

EDIT: Shorting the PSU to start turned on the motherboard power lights. PW SW did not.
Last edited: