Question Gigabyte Z390 AORUS ELITE PCIe x16 issue

Gwyn82

Prominent
May 10, 2017
9
0
510
Since I build this PC I had really bad performance and it took me some time to figure it out that the PCIe works only in x1 3.0 mode (used GPU-z to check it) when it's set in BIOS to x16 by default. When I set it to x8x8 I can see big performance improvement and it works as suppose to (x8 3.0).

Does it have something to do with the M.2 drive? (I've tried both M.2MA and M.2M slot, same results) or there is something wrong with my MOBO? or maybe I'm doing something wrong?

PSU: EVGA SuperNOVA 850 P2, 80+ PLATINUM 850W
MOBO: Aorus Z390 AORUS ELITE (F7 BIOS)
CPU: i7-9700K
GPU: Palit Gaming Pro OC RTX 2080Ti
M.2: Samsung 970 EVO Plus 1 TB
RAM: Corsair CMK16GX4M2B3200C16 Vengeance LPX 16 GB (2 x 8 GB) DDR4 3200 MHz
Audio: Sound Blaster Zx
 
Try it without the sound card installed, as certainly there are enough PCI-e lanes for full GPU operation (X16) and an M.2 PCI-e X4 allocation to an M.2 slot.

There might also be BIOS configuration options pertaining to both M.2 slots, as many mainboard BIOS options include options to share bandwidth with to avoid disabling SATA ports. and, X2/X4 options, etc...

YOur mainboard's manual might detail certain configurations that might trigger x8 GPU operation (certainly 2 GPUs would do this), but, there might be certain rules/notes regarding PCI-e lanes allocation during population of the X4 slot and use of an M.2 drive...
 

Gwyn82

Prominent
May 10, 2017
9
0
510
Try it without the sound card installed, as certainly there are enough PCI-e lanes for full GPU operation (X16) and an M.2 PCI-e X4 allocation to an M.2 slot.

There might also be BIOS configuration options pertaining to both M.2 slots, as many mainboard BIOS options include options to share bandwidth with to avoid disabling SATA ports. and, X2/X4 options, etc...

YOur mainboard's manual might detail certain configurations that might trigger x8 GPU operation (certainly 2 GPUs would do this), but, there might be certain rules/notes regarding PCI-e lanes allocation during population of the X4 slot and use of an M.2 drive...
Tested without sound card. Same result x16=x1, x8x8=x8, x8x4x4=x4.
The only thing I found about M.2 in manual is that it can affect some SATA connectors.
Can't find anything else related to PCIE or M.2 in manual or in BIOS :/
 

Gwyn82

Prominent
May 10, 2017
9
0
510
Returned it. Bought Gigabyte Z390 AORUS PRO this time instead of Elite (for same price) and x16 3.0 out of the box with same config.
Thank you both for help.
 

ASK THE COMMUNITY

TRENDING THREADS