Question Gigabyte Z390 Aorus Pro does not see M.2 SSD's anymore, re-inserting them is a temporary fix.

tomtom1298

Honorable
Feb 2, 2016
115
0
10,680
0
Hello!

My Z390 last week decided to not see my 1 year old 2 M.2 SSD's.
This is the situation:
- Windows nor BIOS sees the M.2 SSD's, unless i re-insert them into their slots.
The Bios states Slot #1 and Slot #2 are "N/A". Weird thing is, i have a 3rd M.2 SSD connected via a bridge into a PCIe-slot, and it sees that one.
- Note: The SSD's worked fine for more then a year.

Is my Motherboard bricked?

This is what i've tried:

  • Clear CMOS, unplugged battery & PSU at same time a few times, didn't fix it.
  • Re-inserting M.2 SSD's fixed it for 3 hours. Out of nowhere the BIOS decided to not see the SSD's, again...
  • Updated BIOS to 1 higher version, but didn't fix. And BIOS does not allow to downgrade...
Based on Samsung Magician, both M.2 SSD's Health Status are good, no bad sectors.
It would be a miracle if both SSD's, broke at the same time.
The motherboard is 1 year and 11 months old. I have 16 days warranty left. However, i don't feel comfortable re-using it after it's been repaired. I assume they can't send me a brand new motherboard, as the production os most Z390 motherboards have stopped, and are mostly out of stock in the Netherlands.

-- Background story --
This is not my first time having issues with this board. I've had plenty of BSOD's, mostly related to voltage problems to my i9. (Mobo officialy supports my i9).
I've brought my PC to a repair shop, and stated SSD's are fine.

I'm gaining some trust issues with Gigabyte. I'm assuming they're not the best brand available.

-- Are ASRock & Asus good? --
I'm considering an upgrade to a Ryzen 9 5950X 16-core and a ASUS ROG Crosshair VIII Hero (X570)

PC Specs:
I9 9900KF, RTX3080Ti, 64GB Corsair Vengeance Pro. 2x M.2 Samsung 970 Evo Plus 2TB*. 1x M.2 Samsung 960 Evo 1TB.
* = Mounted directly into the motherboard's M.2 Slots.
 

sQuiky

Distinguished
Aug 26, 2013
12
0
18,510
0
I'm having somewhat same symptoms with same mobo/cpu combo. In my case fully updated bios, and firmware on SSD's, and checked manual to make sure i didn't conflict with the sata ports.
 

ASK THE COMMUNITY