[SOLVED] Gigabyte Z390 Aorus Ultra Boot Issue

Sep 29, 2019
Hi Everyone,

I recently did my first PC build, so forgive me if I miss something obvious.

CPU: Intel i7-9700k
Motherboard: Gigabyte Z390 Aorus Ultra
GPU: Gigabyte Geforce RTX 2060 Windforce
Ram: 2 X 8GB Corsair Vengeance RGB Pro
SSD: Intel 600p 1TB M.2-2280 NVME
Power Supply: EVGA SuperNOVA G3 650W
Cooler: NZXT Kraken X62

I believe I hooked everything up properly. I can turn it on get in to the bios (Version F6) with no problems (Fans and everything are running). My problem occurs once i try to go past the bios and run the windows installer from my USB. The windows logo pops up to start the process but then as it's loading it freezes about 2ish seconds in. It freezes every time at the same point.

I've tried using multiple USB and live linux. With live linux i ran the memtest on my RAM (got no errors). To do more testing I've tried using only 1 stick of RAM, moving the RAM to a different slot. I removed the GPU , checked the cooling for the CPU (typically 31 C). Lastly I removed the motherboard battery to reset the CMOS and still the problem has remained.

I haven't been able to fully boot yet and use my build. I'm not sure if I have a hardware issue with my motherboard or another component. Or if i need to fix some setting in my bios. Do you guys have any recommendations with how I should proceed?

Thanks for any help you can give.