Question Gigabyte Z390 Gaming X: red cpu light flashes twice and PC will not boot ?

Aug 28, 2022
11
0
10
0
Please keep it to 1 thread
Good morning team,
specs:
cpu: i9 9900k
ram: 32gb crucial ddr 4 3200
gpu: radeon vega 56
psu: corsair 550b bronze
mobo: Gigabyte Z390 Gaming X
os: windows 11

I have the dreaded cpu diagnostic lamp on my mobo flashing twice and no boot at all.
This happened for no reason while booting BF2042.
My system has not changed in 6 months.

The only thing i did last night was change the power plan and left it downloading a game for a few (4 hours) ( which i have done countless times) and then switched off via the power button in the night but all booted up and i played warcraft for a few mins, switched off and loaded bf 2042, all switched off and now i cannot boot. The fans did not go wild just before so i presume no overheat issue.

When i plug in and switch on the power toggle the board lights up so i presume it is not the PSU.
I have unpluggued everything except cpu,fan and 24 pin mobo plug and also removed all ram, drives and usb hubs, 8 pin pcie power cable (still same).
I have removed the cpu and reseated, still no start, same light.
My mobo cpu pins have a couple of bends in them and i only have ram slots 1 and 2 because of this but this has not been as issue in 2 years.
I haver done cmos reset (also changed battery)and also a hard reset of the motherboard ref gigabyte.

This is the weirdest thing but i suppose hardware failure can arrive at any time.
My question is the impossible one. Does anyone think this is the cpu or mobo at fault?
Or a red herring and a psu fault?
Any help or advice i would be grateful for.
much love x
 
Aug 28, 2022
11
0
10
0
In case anybody looks at this. I have diagnosed a faulty psu by doinf the paper clip test, no fans from my psu so there is enough juice to light up the mobo but looks like no more power to do anything else. I'll update tomorrow when the new one comes.
 
Aug 28, 2022
11
0
10
0
Evenin all,
Just a quickee. My mobo lights up when switched on but does not boot (cpu lamp flashes twice). AFter tearing my hair out i have done the jump test for my psu with a ppaper clip and no spinny fans/power. Does anyone agree that the psu is faulty but has enough juice to light up the mobo only? (in my Lamens brain i cannot understand how this would happen but....science!)

specs:
cpu: i9 9900k
ram: 32gb crucial ddr 4 3200
gpu: radeon vega 56
psu: EVGA 600b bronze
mobo: Gigabyte Z390 Gaming X
os: windows 11
 
Evenin all,
Just a quickee. My mobo lights up when switched on but does not boot (cpu lamp flashes twice). AFter tearing my hair out i have done the jump test for my psu with a ppaper clip and no spinny fans/power. Does anyone agree that the psu is faulty but has enough juice to light up the mobo only? (in my Lamens brain i cannot understand how this would happen but....science!)

specs:
cpu: i9 9900k
ram: 32gb crucial ddr 4 3200
gpu: radeon vega 56
psu: EVGA 600b bronze
mobo: Gigabyte Z390 Gaming X
os: windows 11
Even if it's not bad change it.
It's not a very good psu to start with.
 
Aug 28, 2022
11
0
10
0
Even if it's not bad change it.
It's not a very good psu to start with.
It has done me pretty well for at least 5 years so can't complain and i could not justify changing it if i di'nt have to bearing in mind there is a small chance i might need a new cpu or motherboard as well.
I aints made of money...! but ive done it now and gone for a cheapie Evga 750b, fingers crossed.
 

ASK THE COMMUNITY

TRENDING THREADS