Question Gigabytes GA-H110M-M.2 LGA 1151 - no display?

Apr 6, 2021
5
0
10
0
Hi!

I have several Gigabytes H110 motherboards.

By accident think that I did an F20 bios update for H110M-S2H - the wrong bios for GA-H110M-M.2!

I did save the original bios to a usb stick.

Now the computer starts up but doesn't give a Gigabyte boot splash screen or boot into windows - no display!?

Any suggestions of what to do greatly appreciated please?

Thank you,
Philip
 

popatim

Titan
Moderator
Can you get to the bios ?

If yes then you can probably install the correct version using the dos based utility: Dos Flash utilityor right thru the bios ... if you have that option showing in the bios.
To do so follow the Dos instructions from https://www.gigabyte.com/webpage/20/HowToReflashBIOS.html to make your bootable flash drive.
If your bios has a 'update bios' utility then you can just use that instead.

Your drivers , utilities, and bios versions are all here: https://www.gigabyte.com/us/Motherboard/GA-H110M-M2-rev-10/support#support-dl-utility
 
Apr 6, 2021
5
0
10
0
Unfortunately I can't seem to get into the bios!

How can I get into the bios - the computer doesn't show the gigabytes boot screen or make any beeps!
 
The main defense against BIOS brick Gigabyte boards had were double BIOS. Unfortunately for you low-end H110 boards don't have it. And neither do they have BIOS Flashback button allowing flashing the board without working BIOS. So if you really flashed wrong BIOS I'm afraid it's a brick now. The only thing to try is CMOS reset and pray. If that won't help your only option is to replace BIOS chip.
 

ASK THE COMMUNITY

TRENDING THREADS