Google Chrome won't run


Mar 2, 2016
All of a sudden, Chrome won't run. I usually start it from an icon in the taskbar. In the last few days, when I click that icon I get an hourglass for about 10 seconds and then nothing. If I go directly to the program files (x86) folder and try to launch it from there I get the same result... hourglass for 10 seconds and then nothing. I reinstalled Chrome 3 times and it looks like it is installing properly but when I try to launch it, same result. Has Microsoft hijacked my computer? Thanks

EDIT: A few days ago I got the bright idea that YouTube must have an app. I did a Google search and found one, installed it. It's possible that this action was at the same time that Chrome stopped working.

EDIT2: I don't know what I installed but it wasn't YouTube. There is no sign of a YouTube app installation anywhere

EDIT3: I found an unknown file in the downloads list from a few days ago ( Is this the source of my problem? If so how do I eliminate it?

EDIT4: That was an installation of Java runtime environment. I needed it for a Ubiquiti app I wanted to run for my Ubiquiti switch
Last edited:


Apr 16, 2022
Does Brave Browser work? It uses the Chromium back end but it's own front end. So it also uses all the chrome extensions. I mainly use Brave browser.