Question Got a New Network Card but now CPU is 100%

DaCobbler

Reputable
Feb 3, 2015
21
0
4,510
0
Hey. So my family decided to get Gigabyte speed services and I reluctantly agreed to get a network card since it seems like the previous model could 'only handle' >100 mbps (they like 'uniformity' and i'm already a black sheep for using Windows still and not Macs). But upon using Adobe or playing games, my PC goes up to 100% CPU usage and yeah... I think it's likely the Network Card: The D-Link DGE-560T

The CPU not only goes to 100% usage but I hear BRRRRRRRRRRRRRRRM and obviously I don't want to damage the PC (HP Envy 700-038d: i7, Nvidia 1050ti, 6 year old PC)

I tried disabling 'Wake on Magic Packet' and 'Wake on Pattern Match'. I even limited the speed to 10mbps and yet the CPU is still at 100% usage.

Is there any settings I should disable/enable or... should I just revert back to the older NIC?
 

DaCobbler

Reputable
Feb 3, 2015
21
0
4,510
0
Make sure that the NIC's drivers are up to date.

In Task Manager, what application(s) do you have eating all of the CPU cycles?

By the way, the Envy model you listed came with "gig-ether".

https://support.hp.com/us-en/document/c03784239
Thanks for the message. I updated the D-Link DGE 560T driver with one from 2012 (the earlier one was 2011). But it still is using up to 100% CPU

Apart from games or Adobe products, the second main CPU user is Firefox (~10-20%)

I tried disabling more options in the Advanced settings after I read that this Network Card "supports TCP, UDP, and IP Checksum Calculation as well as TCP Segmentation to improve overall system performance by shifting CPU intensive tasks away from your host CPU and onto the DGE-560T adapter itself. "

Maybe there's more settings I have to play with?

I'm trying to use WiFi only now (disabled the DGE-560T in Device Manager) so I'll report back if there's still issues.
 

ASK THE COMMUNITY

TRENDING THREADS