Question GPU and CPU both dip down to 20% and my game lags for a couple seconds.

Jul 2, 2023

I've been having massive issues with some games (Elden Ring,Red Dead 2,GTA IV,Kingdom Come Deliverance)The problem is my CPU after 5-10 mins gets down to lower Mhz and so

does my GPU and then the game has massive lag spikes for a few seconds, and then returns to normal for a few minutes, Graphical settings of the game doesn't matter as shown

in the picture with RDR2 which is on lowest and on 720p. I've tried a lot of things in the software department that meaning tweaks to windows, disabling stuff from bios and

even trying a debloated windows 10 version the settings include, with hardware i tried cleaning my PC and changing my old HDD to a newer SSD and the problem still persists.

The problem is not with CPU or GPU overheating too my CPU stays below 80C and GPU below 90.

My question is could my problem be because of the motherboard and the VRM or maybe PCIE 2?

I'm not that knowledgeable on pc hardware so i hope you could help me.

Here are the pictures View:

The first one is a little useless but the other 2 show how MHz and CPU utilization drop down.

Here are my specs

I7 4790k

GTX 980 ti

8x2 DDR3 ram 1600mhz

H81MHV3 ver 2.0

SSD SP About 500 Write and Read

600W Power Supply

Here's more detail to things I've done

Its not overheating I've had experience with my CPU overheating before and fixed it with thermal paste and a higher quality Fan

Background processes aren't the issue too I've tried with very debloated windows 10 custom iso

I've changed power management settings and customized the advanced settings

I've cleaned the PC

I've replaced my old HDD to a new SSD

I've lowered graphics to Lowest and resolution too 720p

I've set the my GPU on Nvidia settings also used optimized settings

I've Reinstalled windows multiple times

I've disabled unused audio devices from audio settings

I've tested with pagefile size to 0

I've checked my SSD health and its at 99.98% and no bad blocks also defragged it.

I've updated bios

I've disabled Game bar and Game mode i also haven't installed Geforce Experience even tried without Steam

I've installed the latest Nvidia drivers with nvcleaninstall and on previous attempts with GeForce Experience

I updated my Drivers from windows, Downloaded drivers from mobo website

I've uninstalled and installed USB and Bluetooth drivers and tested controller wireless and wired also entirely removed it and only mouse and keyboard

I've also removed any other USB device except the kb and mouse or only controller

I've not Overclocked the CPU or GPU

I've done testing with SSD with 800gb free and currently I have only 200GB free (It's a 1tb)

I've set the computer to use all 8 cores instead of 1 in some advanced settings I dont remember where it was.

I've also disabled some settings in Bios which i dont even remember and after testing i reset it.

My Windows is legit Windows 10 pro

Things i haven't done

Tried a earlier version of GPU drivers with DDU

Tried another Mobo I've read my problem might be with VRM or the PCIE 2 on the mobo

Applied thermal paste again (Last time about a year ago)

A non-cracked version of RDR2, GTA IV, Elden Ring and Kingdom Come i only have GTA IV bought so ill try with it.