Question Gpu Black Screen, Mobo VGA Light On

Apr 16, 2022
2
0
10
0
Howdy all,

I recently transported my pc (relevant specs: corsair cx650m psu, asus rog strix rtx 2060 gpu, tomahawk b450 max mobo, ryzen cpu) and upon booting it up the screen was black, and the vga light on my mobo was on (means gpu not detected). I never dropped the pc and have transported it b4 with no issues. After moving the gpu to the second pcie slot and testing again it worked for approximately 5 mins b4 going black again, and has not worked since on either slot. I tested a friends 1660 gpu on my pc and it worked fine. Assuming a potential driver issue I reinstalled the newest drivers to no avail using his gpu (thanks for no integrated graphics ryzen)

Any advice?
 

ötzi

Proper
Apr 2, 2022
129
30
120
4
Besides that the card is giving no output the card seems to run like normal, fans spinning etc? Seems to have died during transport, even though you transported your PC before with the GPU still installed, you should always remove it if it has no support brackets, and even then.
 
Last edited:
Apr 16, 2022
2
0
10
0
Besides that the card is giving no output the card seems to run like normal, fans spinning etc? Seems to have died during transport, even though you transported your PC before with the GPU still installed, you should always remove it if it has no support brackets, and even then.
Any idea what specifically might be wrong with it? Im not keen on just giving up on a spendy gpu.
 

ASK THE COMMUNITY

TRENDING THREADS