Question GPU blinking red light? PC won't start?

Apr 5, 2020
4
0
10
0
So I recently purchased an RX 5700 XT gpu for my computer and attempted to replace my existing RX 580 with it. Nothing occurred upon power up - only a single red blink from an LED light on the new GPU when I attempted to power the PC on. I then proceeded to remove this new card and put in my old one (RX 580) and same thing! One red blink of the led light on the gpu and nothing. This occurs everytime I attempt to unplug the psu and plug back in, and press the power button - just a single red blink and nothing (absolutely nothing runs). I have made sure to remove all connectors and plug them all back in (ensuring they were all sat correctly), and I made sure the ram was connected properly. I also reset the CMOS by replacing the battery and waiting, and placing it back in.

Computer Type: Desktop
GPU: XFX RX 580 (currently in). XFX RX 5700 XT Raw II (trying to install once this issue is resolved)
CPU: Ryzen 5 2600x
Motherboard: MSI XR 470 Gaming Plus
RAM: 16 GB (2 x 8 corsair sticks)
PSU: EVGA 600 W 80plus
Operating System & Version: Windows 10
GPU Drivers: up to date drivers
Description of Original Problem: Review above
Troubleshooting: Review above

The only thing I think it could possibly be at this point is a shorted and now faulty PSU.. which has led me to order a new one.
 
Apr 5, 2020
4
0
10
0
Yeah i was about to say is it the red LED next to the power connection? If so then it is a power supply issue presumably.
Yes it's a tiny LED light next to the 8 pin connector on the graphics card. My huge concern with this is that this is the second PSU that's been fried over the last 6 months with this PC.. I have 0 clue what I've done to have this happen

I've also conducted the paper clip test on the PSU, and no life from the fans
 

ASK THE COMMUNITY

TRENDING THREADS