Question GPU, CPU and RAM are somehow underperforming with highend gear

Aug 3, 2020
4
0
10
0
Hello together,

I have a big problem that makes me angry lately.

Following specs:

GPU: RTX 2070
CPU: Ryzen 7 2700X
RAM: 2x8 GB of 3200 MHz Corsair DDR4
Some water-cooling and many fans.
240 Hertz monitor with full HD
HDMI cables
2x 500 GB Samsung ssd.
X470-F Mainboard am4

So.
In every game I have low fps.
And that is because somehow my ram is always capped at 50% usage. My gpu at the peak somewhere around 40% at max. CPU sometimes more. I tried many many solutions this far and nothing helped. Please for the love of God somebody can help me.

Sincerely Jakob
 

Ralston18

Titan
Moderator
16GB RAM installed - correct? What actual amount is being shown as being used?

Use Task Manager and Resource Monitor to observe system performance.

Use only one at a time though

Make your observations three ways: First while the system is just idling. Second while doing light work and browsing. Third while gaming.

Determine what resources are being used, to what extent (%), and by what.

Pay close attention to the Memory tabs. Clicking the column headers can sort the data and make it easier to watch.
 
Aug 3, 2020
4
0
10
0
So yeah I already did all of that. Including much more. I see a 2% cpu usage 1% gpu usage and like 30-35% usage of RAM when I am not doing anything. How it is in games I posted in the top. When doing slight work the ram usage increases but it's way under 50%. Cpu increases of course and gpu maybe by a couple percent. I really tried much so far. And I didn't find any solution by now... Sincerely Jakob
 
Aug 3, 2020
4
0
10
0
What is awkward too, as i said it only occurs in games and rendering programms. When i benchmark my gpu will have 100% and RAM will have much more than 50% too. So i dont quiet get that to be honest.
For what i tried so far:
  • Updating litererally anything. From Bios to Chipset to graphiccard
  • Enabling D.O.C.P in Bios for not 2133 Mhz -> 3200Mhz
  • Setting global setting in nvidea control pannel to maximize for power
  • Clean Install with no files kept of windows
  • "Playing" with cores
  • Playing with Virtual Ram´
 

Ralston18

Titan
Moderator
No need for personal conversations.

From your PM to me.

"In games where i want my hardware to go over 70%ish to give me good fps it doesnt happen.
For example in Conquerers Blade i only have about 40-60 and it doesnt matter on which graphic settings i play.
My Taskmanager and ingame OC shows me a RAM usage of only 50% always. Then its like 40-50% GPU usage and same goes for the CPU
I tried everything but cant find a solution. When benchmarking my gpu goes to 100% and my cpu over 80%..... "

Please post all additional information and updates to this thread so anyone else who is following will be kept "in the loop". Thanks.

The key is to discover why only 50% of RAM is being recognized. Are the installed RAM modules from a matched set?

Immediate suggestion:

In the "Type here to search" box in the lower left screen corner type "Windows Memory Diagnostic"

Run the diagnostic via the recommended restart.

Post the results.
 
Aug 3, 2020
4
0
10
0
So i did that and nothing showed up. In the taskmanager and BIOS it tells me i have 16 GB of RAM installed 3200 MHz. Its from the same set yes. Corsair Vengence 2x8 GB 3200 MHz. Now i have a question.
A friend of mine tried something yesterday on my pc. He ran FurMark to stresstest. In that test my GPU was at 100% usage, my Ram way over 50% and my CPU was at 70-80%. So that would be perfect right? So he did another cpu test at the same time and then things got awkward. The GPU Usage fell from 100 to 40 in one second and the CPU usage was 100%. So he thinks that probably smth is up with my PSU and we will test today. Sincerly Jakob
 

ASK THE COMMUNITY