Question GPU does not display anything past the BIOS ?

May 9, 2021
2
0
10
0
Hello, my GPU (RX 580 8GB) stopped displaying anything happening to my computer after the bios finishes (if im correct, the bios is that ASRock screen with spinning cirlces). I think its a problem with my GPU as this isnt the first time this happened.

The first time it happened was after I tried to update my radeon software using auto detect from AMDs website. I rebooted after it told me to and my computer stopped displaying anything past the bios. After a few hard resets I entered the recovery mode & tried to use that diagnostic feature, it found nothing. I then tried to enter safe mode, safe mode didnt work as my GPU didnt display anything. I got my computer repaired by a professional and it worked fine for quite some time.

This time, the same issue started happening, and I dont know how to fix it myself, could someone help me?

System specs:
Intel i3 8100
RX 580 8GB GDDR5
8GB DDR4 RAM
ASRock motherboard
As for the PSU im not sure.

Also, I only have one monitor thats 1440 x 900
 

Colif

Win 10 Master
Moderator
one way to get vision back would be remove GPU and plug monitor into motherboard instead and use the intel cpu to run graphics. Not ideal. but you could run ddu in safe mode and remove the AMD drivers
and then put card back in and see if you can get windows to load drivers that work for it.

I don't know what repair guy did, maybe had a spare Radeon he knew worked,, installed drivers with it in PC and swapped yours back in - just a guess.
 
May 9, 2021
2
0
10
0
one way to get vision back would be remove GPU and plug monitor into motherboard instead and use the intel cpu to run graphics. Not ideal. but you could run ddu in safe mode and remove the AMD drivers
and then put card back in and see if you can get windows to load drivers that work for it.

I don't know what repair guy did, maybe had a spare Radeon he knew worked,, installed drivers with it in PC and swapped yours back in - just a guess.
I did what you suggested by using ddu in safe mode without the GPU and I was able to get my computer back up and running, thank you. Maybe a possible cause could have been the amount of dust that built up inside my computer but I dusted it now.
 

ASK THE COMMUNITY