Question Gpu fan spins but no display and burning smell is coming

Jan 22, 2021
2
0
10
0
My PC specs -ryzen 5 3600
Ram -8gb corsair vengeance
Mother board -MSI pro carbon ac gaming pro mono WiFi +blue tooth
GPU -1050ti
Psu- corsair 550watt PSU white certified
I was using my old 750ti with the same specs above it was working fine for 2-3/months than I upgraded to gtx 1050ti and it was working fine for a month and suddenly one day when I was playing apex legends the display was gone and burning smell was coming from the GPU but the fan was working than I replaced my gpu under warranty and but it happened again with the replaced one to I have a VGA 720p lg monitor so I was using a HDMI to VGA converter pls help me :/
 

alceryes

Distinguished
Have you been monitoring your GPU/CPU temps? Does your case have adequate cooling (cleaned of all dust)? It's possible that your PSU is at fault but the only way to test would be to install a better PSU.
Try running just a CPU stress test for a bit and see how it goes. Prime95 blended test with all AVX off for 30 mins. If it passes that, try running Realbench for the same amount of time (with half your memory selected).
 
Reactions: Praney singh
Jan 22, 2021
2
0
10
0
Have you been monitoring your GPU/CPU temps? Does your case have adequate cooling (cleaned of all dust)? It's possible that your PSU is at fault but the only way to test would be to install a better PSU.
Try running just a CPU stress test for a bit and see how it goes. Prime95 blended test with all AVX off for 30 mins. If it passes that, try running Realbench for the same amount of time (with half your memory selected).
Yes i my PC is dust free and have adequate cooling with normal temps ,when I went for the exchange the service center worker said to update the bios but it is already updated
 

ASK THE COMMUNITY