Question GPU fans do not spin, when turning the PC on, also no display, how to fix?

St1rx

Commendable
Oct 19, 2020
5
0
1,510
0
Hello!

I built this PC a few years ago and just today, when I was cleaning the PC from dust and trying to boot it up again, everything except the GPU turned on (fans didn't spin) and did not get a display signal. My specs:
CPU: Ryzen 3 3100
GPU: Gigabyte RX 570 8gb
RAM: Patriot Viper 8x2 16gb 3200mHz
Motherboard: B450M-A Pro Max
PSU: Xilence XP500W Bronze
Everything is stock, nothing is overclocked
I do not have a secondary PC to test the GPU or any other component
What should I do?
Any help is appreciated!
 

DSzymborski

Titan
Moderator
It's surprising your GPU ran this long, with a fake 500W PSU.

If you can't test or buy anything, there's not much to do other than rebuilding the PC yourself, making sure everything's connected. We have a checklist.


(Don't just look at them and say "OK, I did that," actually go through the list one-by-one).

After that, a local shop can test what component failed.
 
Reactions: Dark Lord of Tech

St1rx

Commendable
Oct 19, 2020
5
0
1,510
0
It's surprising your GPU ran this long, with a fake 500W PSU.

If you can't test or buy anything, there's not much to do other than rebuilding the PC yourself, making sure everything's connected. We have a checklist.


(Don't just look at them and say "OK, I did that," actually go through the list one-by-one).

After that, a local shop can test what component failed.
What do you mean it's a fake PSU? Should I be worried and change it immediately?
 

ASK THE COMMUNITY

TRENDING THREADS