Question GPU had no display

Mar 15, 2020
9
0
10
0
Hi guys I need help about my GTX 1080 FE

So recently I just reapply a new thermal paste to my GPU and it's was working fine...
Until the Graphics card decided to not showing any display after I shut it down

It does have flicking no signal on my monitor while using HDMI port and I assume its trying to deliver the image to my monitor but it got cut off
(Will provide video later)

I tried to switch to the other cable which is VGA with a HDMI converter and the flickering is gone but still had no display

Is there any way to fix this? Or my GPU is faulty

Lights on my keyboard and mouse are on so I assume its booted just don't have display
And I have yet to try out the other display port cause I don't have the hardware

Spec:
Ryzen 5 2600
16 GB ram
GTX 1080 FE
650w PSU
 
Jan 21, 2021
12
3
15
0
a good idea might be to try another hdmi cable also is there any posibility to check the monitor or try to connect the pc on a tv at last another gpu or a cpu with onboard graphics generally try to narrow the problem to the faulty component it might not be your gpu
 
Mar 15, 2020
9
0
10
0
a good idea might be to try another hdmi cable also is there any posibility to check the monitor or try to connect the pc on a tv at last another gpu or a cpu with onboard graphics generally try to narrow the problem to the faulty component it might not be your gpu
Did tried to use another HDMI cable but seems like it's getting worse no flicking no nothing
Might try it on TV though and see if it works
 
Jan 21, 2021
12
3
15
0
idk it looks to my like a faulty cable HDMI can be very nasty because you have mixed results with every cable i suggest try as many as you can .i had to try three different cables for my monitor to properly sleep after i shutdown my pc all of them same standards(it was flickering like yours). try the tv and let me know .
best of luck
 

ASK THE COMMUNITY