Question GPU is not detected by monitor when first open.

max13

Commendable
Aug 23, 2019
148
7
1,595
2
Hello everyone,
I have a problem with my GPU RX 5700XT.
It doesn't post when I open the PC, I had to unplug the DP port and put in the DP cable again then it will display on the monitor.
And it's still playable, I still can play games for a long time, with no issue.

So I tried it with the HMDI port as well, still facing the same problem. I tested both cables with my laptop, it's running fine.
I changed both cables, and still facing the same issue.

I need help. I don't know what is going on with my GPU.
Do you guys have any idea what might cause the issues?

Thank you all very much.
And sorry for my broken English.

My full spec
I7 10700
RX 5700XT
MSI z490 gaming plus
Corsair 750w 80+ plus gold

Monitor LG-27gl83a-b

OS: Windows 10

EDITED: Update my full specs.
 
Last edited:

Ralston18

Titan
Moderator
Your English is fine.

Update your post to include full system hardware specs and OS information.

Include PSU: make, model, wattage, age, condition (original, new, refurbished, used)?

Make and model monitor?

Try running the built in Windows Troubleshooters. The troubleshooters may find and fix something.

If that does not work then manually download the GPU drivers via the manufacturer's website. Reinstall and reconfigure.

No third party installers or tools.
 

max13

Commendable
Aug 23, 2019
148
7
1,595
2
Your English is fine.

Update your post to include full system hardware specs and OS information.

Include PSU: make, model, wattage, age, condition (original, new, refurbished, used)?

Make and model monitor?

Try running the built in Windows Troubleshooters. The troubleshooters may find and fix something.

If that does not work then manually download the GPU drivers via the manufacturer's website. Reinstall and reconfigure.

No third party installers or tools.
Thank you very much for the help,
I updated my spec and i tried what you told me to.
Still facing the same problem here.
I will clean and re-install windows 10 again.
 

Ralston18

Titan
Moderator
How are you reinstalling Windows?

FYI:

https://forums.tomshardware.com/faq/windows-10-clean-install-tutorial.3170366

However, before trying another Windows install.....

This monitor?

https://www.lg.com/us/support/product/lg-27GL83A-B.AUS

Do verify that I found the applicable Owner's Manual.

Read through the Owner's Manual to verify that the monitor is correctly configured for HDMI.

User configurable settings are presented beginning on physically numbered Page 20 of the Owner's Manual.

Check everything but be sure to check HDMI Compatibility Mode on Page 27.
 

max13

Commendable
Aug 23, 2019
148
7
1,595
2
How are you reinstalling Windows?

FYI:

https://forums.tomshardware.com/faq/windows-10-clean-install-tutorial.3170366

However, before trying another Windows install.....

This monitor?

https://www.lg.com/us/support/product/lg-27GL83A-B.AUS

Do verify that I found the applicable Owner's Manual.

Read through the Owner's Manual to verify that the monitor is correctly configured for HDMI.

User configurable settings are presented beginning on physically numbered Page 20 of the Owner's Manual.

Check everything but be sure to check HDMI Compatibility Mode on Page 27.
Thank you very much for the help, I really appreciated that.
I did everything you told me, still not working.
So I sent my GPU to the shop and they told me it would take like 1-2 months.
Since my GPU is now old and there is not a lot of stocking left so it'll take longer than usual.
 

ASK THE COMMUNITY