Question GPU leds power on and off rapidly before going into bios

Sep 25, 2020
11
0
10
0
I bought a palit 2060super dual and when I open my pc the leds on the card flickering, is that normal behavior ? because it works just fine once it shows the motherboard logo and while using the computer everything seems to be normal


pc specs:

Ryzen 5 3600
B450 mortar
palit 2060 super dual
16gb team elite ram
bequiet pure power 11cm 700 gold
 
Sep 25, 2020
11
0
10
0
Hqave you tried using Geforce Experience (LED visualisation) - maybe try turning the LEDs off.
No, I haven't tried that yet, I can't see how to change LEDs using geforce experience too, I can turn the light off with thundermaster and try if it does not flicker at startup anymore, it really just worries me.

Do you mean the RGB
View: https://youtu.be/_lxQQx5cHno?t=128


or a single LED on the card next to the power connection cable?
My card isn't really rgb too, there is just a white LED bar on tha card that lights up when powered on, the flickering only happens during startup though
 
Last edited:

SteveRX4

Notable
BANNED
Sep 29, 2020
1,477
135
890
19
My Radeon vii has a light in it too. If it was flickering then my guess is that there's something wrong with the led/s. I'm not sure whether it'd be the led or the power to it.
I think you'd have to open it up to have a look.
Either that or just cover it up.
 
Sep 25, 2020
11
0
10
0
My Radeon vii has a light in it too. If it was flickering then my guess is that there's something wrong with the led/s. I'm not sure whether it'd be the led or the power to it.
I think you'd have to open it up to have a look.
Either that or just cover it up.
Oh ok so it might just be the Leds and not something about drivers or the power supply?
 

ASK THE COMMUNITY

TRENDING THREADS